Operating System Not Supported

Technical Support
Just completed patch to 2.6.1 and clicked play.
game does not open, instead get a dialog box that says...

Title: Operating system not supported
Message: Diablo III requires at least Windows 7 to run.

im on Win10 pro, this just started after the 2.6.1 patch.
any ideas?
Do you currently have compatibility settings set on any of the Diablo III executables? You'; want to check Diablo III Launcher.exe and Diablo III.exe in the Diablo III folder. Be sure to also check Diablo III64.exe in the Diablo III\x64 folder.
Same happened to me and i'm on windows 8.1 No idea what to do
10/27/2017 12:16 PMPosted by Zhyxen
Do you currently have compatibility settings set on any of the Diablo III executables? You'; want to check Diablo III Launcher.exe and Diablo III.exe in the Diablo III folder. Be sure to also check Diablo III64.exe in the Diablo III\x64 folder.


I checked these settings. None of the boxes are checked
@Zeus
Mind posting a DxDiag report?
10/30/2017 06:29 AMPosted by Zhyxen
@Zeus
Mind posting a [url="https://us.battle.net/support/en/article/Obtaining-System-Files"]DxDiag[/url] report?


I got it. This time when I started battle.net it told me compatibility mode was detected. I must have missed checking the right one earlier. Thanks!
Dear Zhyxen
Your Instructions Are Correct. Thank You!!!
Running Windows 8.1 Just Double Clicked on Diablo III Launcher.exe and Diablo III.exe in the Diablo III folder

(OLD DIABLO 3 (RED ICON).

Kind Regards,
Nano~Black

Join the Conversation

Return to Forum