New update, won't download.

Technical Support
Downloading at 0 B/s and it's been that way for about 30 minutes now after logging in. Help?
same
same with me cant play the game. plz help
Same here. Stuck with having 5 MB's left to download and sitting at 0 download speed.
Same.
same..... 9,06mb and 0 B/s
Tried everything and nothing happens.
same
same
Hey everyone,

If it has not completed its patching yet then lets go through the following:

* Change settings in the app to no longer automatically update games. You can do this by clicking the Blizzard logo in the upper left hand corner and go to settings, then game install/update. Once there scroll to the bottom to the Game Updates section and turn off Automatic Updates. I do also suggest checking the network bandwidth and make sure its not set to a strange number like 12 or 30.

* Go ahead and shut down the Blizzard Launcher and delete the following 2 folders:
Battle.net cache
Battle.net files


* Launch the app again and before patching run scan and repair.

* You will also want to check proxy settings. Sometimes these do like to cause trouble.

~ Zayssie
Did every step given. Still does not work.
after applied your solution i see - fetching encoding table 63.60 KB/244.87 KB .. network problem..
another game can be download, internet working fine, no proxy, no another problems ...

help pls.
Hey there!

I relayed your information to Zayssie, who is unable to respond directly today. after discussing this we think something is interfering with the app and its ability to apply updates to the game. The following should tackle those particular causes and hopefully clear this up.

Try running your system in selective startup mode.

I recommend running a full system scan using the free online scanner from ESET.

Once that is complete I then would like you to temporarily uninstall (disabling the programs often causes them to clamp down even more) all security software currently on your system and then restart the computer. Test the game. Once you have completed testing I recommend putting some sort of security programs back on.

Finally, perform Steps 1-5 of this article.

Do not reinstall yet but follow these additional steps:

1. Open file explorer/file manager
2. Type the following into the address bar (not the search bar): %APPDATA%
3. Delete the Bnet and blizzard folders inside the appdata folder if they exist.
4. Repeat steps 2 and 3 with %LOCALAPPDATA% and %TEMP%
5. Empty the recycle bin.

Now reinstall the app to the C: Drive and have it relocate your games. This should get you around the issue at hand.
Nope, none of this worked. Maybe tomorrow I will try the hassle of uninstalling and reinstalling the whole game.

UPDATE: I literally just let it sit while I was going to fill out a ticket and low and behold it notified me it was ready and playable.
go figure.
hi, now is working .. after few hours seems solved. blizz solved it? thank you
y wont diablo 3 update stuck at 4.86mb
bump
Bump
bump

Join the Conversation

Return to Forum