Diablo III64.exe - Bad Image?

Technical Support
Hi all, I have been getting this error message for a few days now and not to sure how to correct it. What happens is, when I open DIII from the Blizz App or the DIII Shortcut, The launcher opens and I hit play, but then this message pops up.

c:\Program Files (X86)\Diablo III\x64\icuuc57.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x0000020.

So I close the launcher and then reopen it after. When I do this the launcher initializes and quickly downloads something and the play button is active. I then click play and I can enter the game fine.

I was just looking or a way to clear this error, and fix the problem. I have run the in game scan and repair, but the error persists.

Any help would be great. Thanks.
Any suggestions?
Have the same problem here
Hi All,

I am still looking for a resolution for this error, any help would be great.

Thanks,

Ickabod
Hey all,

This error usually means either that a game file is damaged or that Windows/Driver are out of date. Sometimes this could mean there is a conflict with another program. First, we will want to make sure there are not any damaged files and that everything is up to date.

• Run the Diablo III repair tool.

• To be on the safe side make sure Windows and the drivers in the computer are up to date.

• Run the computer in a selective startup mode.

• Please uninstall and then reinstall Diablo III
Have done all that several times plus reloaded a clean windows install. Still get the same error.
I have also done all of the above, and yet it still persists. Its not a game breaker by no means, just a little annoying to have to start the launcher, then get the error, then have to restart the launcher so it will initialize a small patch. I wonder if i remove the bad file in question, the restart the launcher so that it can patch itself, may that would fix it.

So remove this : c:\Program Files (X86)\Diablo III\x64\icuuc57.dll

What do you think?
Same issue and error here as OP. Seems like it started happening after the latest Blizzard app update.
I also have this problem.
I am having a similar issue after the latest patch for Season 13:

The program can't start because VCRUNTIME140.dll is missing from your computer.
Try reinstalling the program to fix the problem.

Click OK

Then:
The program can't start because MSVCP140.dll is missing from your computer.
Try reinstalling the program to fix the problem.

Click OK

Then:
Critical error during loading process.
Required library icui57.dll does not exist.

I've checked for driver updates, reinstalled DIII.
All other Blizzard titles run from the launcher with no issue.
It seems that today after a requierd blizzard app restart, this happend:
Failed to load.
Critical error during loading process.
Required library icuin57.dll does not exist.
jesus again? didnt we just patchwreck yesterday
Looks like were patching again guys. Fingers crossed.

Join the Conversation

Return to Forum