Diablo 3 stops responding as soon as I enter a game

Technical Support
As soon as I enter a game before I able to move at all my game freezes. I can't even ctrl + alt + del to close it (task manager opens but it's non responsive). The only solution is to restart or log out.

Anyone have any ideas?
I am having this issue as well
I have an ssd, 100MB connection, 16 GB ram, i7 processor gtx9600. Never had this problem until about a month ago.

I completely uninstalled both diable3, and blizzard app.

Went into appdata and removed any blizzard or Diablo3 stuff, went into program data, and program files and did the same thing. Literally as soon as I start to enter the game it remains totally frozen, no sound, CTRL-ALT-DEL only option that works for me is log off. Totally locks up the computer and the hard drive activity light is SOLID.

Eventually after a few times it runs correctly
Freezes or you can hear the sound? My game loads up with a black screen and I can hear the game.
Try this, tell me if it works... If you're using windows 10 just search D3Prefs.txt in your search bar for your PC if you don't know where it is located.

1. Edit your D3Prefs.txt.
2. Change the DisplayModeWindowMode "0" to DisplayModeWindowMode "1"
3. Launch game

Let me know if that works. It's not acceptable for me to play at that scale but I can see the game working now. :(
11/21/2017 05:55 AMPosted by Amoeba
Try this, tell me if it works... If you're using windows 10 just search D3Prefs.txt in your search bar for your PC if you don't know where it is located.

1. Edit your D3Prefs.txt.
2. Change the DisplayModeWindowMode "0" to DisplayModeWindowMode "1"
3. Launch game

Let me know if that works. It's not acceptable for me to play at that scale but I can see the game working now. :(


All that does is puts the game in a windowed mode. that is not a solution to this issue. Blizzard needs to put up a stickey on this matter. Hearing nothing from them is zero support
Hey all,

As a workaround, you can also try putting Diablo III in Windowed Fullscreen mode. DisplayModeWindowMode "2"

To find out why this is happening and find a more permanent fix, please post a DxDiag and Diablo III Error Logs. Paste the DXdiag and Diablo III Error Logs into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.
I had this issue, running Win10 64-bit fully updated, D3 in both 32-bit and 64-bit client had this issue.
16gb RAM
i5 Quad-core CPU
970 GPU.
And the game on an SSD.

However, what fixed it for me, was leaving a couple of the communities I was in. This instantly resolved my freezing/stuttering issues upon joining games.
Give it a try yourself.
This has been happening to me a lot. It is random, doesn't appear to coincide with network performance, and nothing I have tried so far has resolved it. Some steps seemed to work temporarily, but it always comes back with a vengeance. I know the game is "running" because when I come back after exiting the game, actions I took while "frozen" did complete (like identifying items, picking up items, etc).

Very frustrating and I haven't seen any resolutions posted by Blizzard. Granted I haven't submitted a ticket, was just hoping to find a fix before I go to the trouble.

No other game I play requires this level of "tweaking" just to get it to work properly and consistently....just saying :P
I don't know if this helps at all, but I found a file D3Debug.txt, and this is the logging from when the freezing first started to when it disconnected (this time). Sometimes it doesn't disconnect, but comes back "alive". Very random, but makes game-play extremely difficult.


2017.11.21 16:44:12.179950600 Enabling loading screen for 4, 4
2017.11.21 16:44:12.184802600 Initializing client world a3Dun_Keep_random_02_Level_02...
2017.11.21 16:44:12.189387300 Enabling loading screen for 4, 4
2017.11.21 16:44:12.194534300 Disposing UI for World
2017.11.21 16:44:12.207412300 Disabling loading screen for 1, 4
2017.11.21 16:44:12.259516600 Disabling loading screen for 2, 4
2017.11.21 16:44:12.264085600 Disabling loading screen for 4, 0
2017.11.21 16:44:55.547258300 [Telemetry] (TELE): Requested sending batch messages by multi-part http POST messages count 1
2017.11.21 16:45:47.172551300 de activate app 0 iconic 0
2017.11.21 16:46:20.944824300 ACTIVATE APP 1 iconic 0
2017.11.21 16:46:45.240920300 de activate app 0 iconic 0
2017.11.21 16:46:55.550364600 [Telemetry] (TELE): Requested sending batch messages by multi-part http POST messages count 1
2017.11.21 16:47:24.160958600 ACTIVATE APP 1 iconic 0
2017.11.21 16:47:36.855369000 de activate app 0 iconic 0
2017.11.21 16:47:49.578367000 ACTIVATE APP 1 iconic 0
2017.11.21 16:48:11.133290000 de activate app 0 iconic 0
2017.11.21 16:48:49.638248300 ACTIVATE APP 1 iconic 0
2017.11.21 16:48:55.571985000 [Telemetry] (TELE): Requested sending batch messages by multi-part http POST messages count 1
2017.11.21 16:48:57.709997300 Applying changed prefs
2017.11.21 16:48:57.714959000 dpi = 96 96
2017.11.21 16:48:57.724883300 Opening Direct3D11 in 2560x1440 fullscreen windowed mode.
2017.11.21 16:48:57.745970600 Reset() Attempt started!
2017.11.21 16:48:57.781430600 Setting depth texture, fmt = 30
2017.11.21 16:48:57.787945000 PostFXGfxInit() success
2017.11.21 16:48:57.792175600 SubObjectGfxInit() 1
2017.11.21 16:48:58.096577600 Completed applying changed prefs
2017.11.21 16:49:11.291821600 de activate app 0 iconic 0
2017.11.21 16:49:46.974945600 ACTIVATE APP 1 iconic 0
2017.11.21 16:50:55.577090000 [Telemetry] (TELE): Requested sending batch messages by multi-part http POST messages count 1
2017.11.21 16:51:20.035695300 de activate app 0 iconic 0
2017.11.21 16:51:57.895172000 recv() failed: Connection reset.
2017.11.21 16:51:57.902247600 ClientSocket Disconnect
2017.11.21 16:51:57.906781000 UIStartup_ClientDisconnected msg=The game connection has been lost: your client has been disconnected from the server.
2017.11.21 16:51:57.910929600 Disabling loading screen for 31, 0
2017.11.21 16:51:57.915100000 >>> Desmond ===== Battle.net SetD3GameServerDisconnected (expected=0) ===== The game connection has been lost: your client has been disconnected from the server.
2017.11.21 16:51:57.919268000 >>> Desmond ---------------- ModalNotificationManager::SetOkNotification: The game connection has been lost: your client has been disconnected from the server.
2017.11.21 16:52:00.446657000 ACTIVATE APP 1 iconic 0
2017.11.21 16:52:02.483155300 GameDisposeGames()
2017.11.21 16:52:02.487987000 ENDING GAME
2017.11.21 16:52:02.494045000 Disposing UI for World
2017.11.21 16:52:02.502540300 Client Disposed world.
I have the same issue has a fix been posted?
Same issue. Just started with Season 12. Very annoying as nothing working so far.
freeze by 2
Same issue, either freezes at moving diamonds or the moment I enter a game. Been waiting for fix but nothing comes.
I started having this issue on the 15th right after the windows update.
I have the same issue and this is very annoying when I begin a new game. This isn't happening with any other game I play and it needs to be fixed on their (Blizz) end, not ours.
my game has been freezing and having not responding 3 to 4 times a day while actively playing, please look into it
11/20/2017 04:04 PMPosted by Boobey
As soon as I enter a game before I able to move at all my game freezes. I can't even ctrl + alt + del to close it (task manager opens but it's non responsive). The only solution is to restart or log out.

Anyone have any ideas?
It is getting very frustrating dealing with no support from Blizzard after 13 years of playing this Game this is the worst Ive seen.
As soon as i enter the Game the game freezers ,i have uninstalled and re installed the game 3 times now but no luck still the same.
they are quick to Take your Money but when it comes to support well that's another issue.
at least you cant complain about the service ,because there is none !

Join the Conversation

Return to Forum