Screen Flicker

Technical Support
Diablo III Screen Flicker

Hi folks. I have a screen flicker problem that just started today. I don't think it is the last update because I played for a day fine on that. Nothing else flickers, just D3. Anyone else having this problem?
Hello Odin : Have you tried turning Vertical Sync ON ?

From the main menu, ESC + Options + Video (about half way in the left column).

Good luck.
Hi Odin,

If Boubou steps work, please post that they did. If not , could you post back with a DxDiag? This will let me help find what is going on. In the meantime, does this happen in Windowed mode?

DxDiag

Please post a DxDiag:
    1) Press Windows Key + R.
    2) Type DxDiag and press Enter.
    3) In the DxDiag window, click Save All Information.
    4)Name the file "dxdiag" and click Save
    5) Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.


/Nathardrick
The same problem started for me today. I did the Vertical Sync and that seems to have fixed it. For now at least.
Same problem started for me to day as well, going to try the Vert Sync.
Same problem here.
12/13/2017 07:30 PMPosted by Nathardrick
Hi Odin,

If Boubou steps work, please post that they did. If not , could you post back with a DxDiag? This will let me help find what is going on. In the meantime, does this happen in Windowed mode?

DxDiag

Please post a DxDiag:
    1) Press Windows Key + R.
    2) Type DxDiag and press Enter.
    3) In the DxDiag window, click Save All Information.
    4)Name the file "dxdiag" and click Save
    5) Paste the DXdiag into the post, select and highlight everything you just pasted, and hit the "code" button (</>). That'll make the information much more readable.


/Nathardrick


Problem found it's the game server settings that are out of sync by fixing this problem it's in the game settings due to video upgrade from the main server to prevent the screen flickering go to the game options and go into the video look for the vertical sync and check mark it apply to the game and it should stabilize the video til blizzard fixes their problem on their end.
12/13/2017 06:49 PMPosted by Boubou
Hello Odin : Have you tried turning Vertical Sync ON ?

From the main menu, ESC + Options + Video (about half way in the left column).

Good luck.


That worked for me. Thanks.
Hey, everyone!

We are still collecting information for this issue. If you have this issue (or used one of the workarounds to address it) please send an email titled Flickering Issue [Your Forum Name] to techinfo@blizzard.com with the following:

  • MSINFO and DXDIAG
  • Answer the following questions:
  • When did this start happening?
  • What have you done to address it?
  • Does it affect any other non-blizzard games or programs?
  • Any other information you can provide will be helpful. :)
    Happy Holidays, everyone!

    Just wanted to provide an update on the situation, apologies for the delay. It appears that this seems to be related to using the Microsoft Drivers after an update for Intel cards mostly. There's been reports of it happening in other games and even streaming (Movies, Youtube, etc.)

    The work arounds have been a hit or a miss, but feel free to try them!
    • Scan and Repair
    • Windowed Mode
      For Diablo, you will be able to do this in-game or head to the Blizzard App's Settings > Game Settings, then locate Diablo and check Additional Command Line Arguments. Type in -w or -Displaymode 0
    • Turning on V-Sync
      For Diablo, press ESC, then head to Options > Video in-game, and check Vertical Sync

    Performing a DDU and installing the manufacturer's drivers should resolve the flickering, especially if you may experience this outside of gaming :)
      1. Download the Display Driver Uninstaller from The Wagnard Forum. (Click on the latest Announcement that should say "Display Driver Uninstaller," then at the bottom, click on "Official Download Here")
      2. Run the Display Driver Uninstaller and extract the files.
      3. Click on Display Driver Uninstaller and run it. Running this in safe mode will yield better results. (You can do so by pressing Windows + R, type in msconfig, then go to the boot tab. Check Safe boot and Network. Apply and OK, restart!)
      4. Click on Clean and Restart.
      5. After restarting, install the Intel Drivers here. If you may have AMD or NVIDIA, you will be able to find your drivers here for Nvidia and here for AMD.

    If the problem continues, please contact our Technical Support team!

    Happy Gaming!
    ive been facing the same problem for the past 2 weeks finally found this info turned on vertical sync all good now thanks everyone so much
    Not sure if I'm having the same issue as everyone else here but every time I click on something in my inventory my entire screen flashes negative colors for a split second.

    Already have V-sync on.

    This just started 5 days ago or so.
    12/30/2017 08:44 PMPosted by Add
    Already have V-sync on.
    Have you tried the other suggestions Caterpepi made ?
    12/13/2017 06:49 PMPosted by Boubou
    Hello Odin : Have you tried turning Vertical Sync ON ?

    From the main menu, ESC + Options + Video (about half way in the left column).

    Good luck.


    Ok I was looking for what could fix this for me and it worked for my computer.

    Thank you for posting the option to try.
    I started having this issue two or three days ago, (first time logging in since before the holidays), & toggling on Vertical Sync fixed it for me. Thank you, everyone! I'm excited to farm the last few enemies I didn't kill in the Anniversary Event last year.
    +1 to the vscync fix, wifey's laptop got hit by it.
    Activated vsync - so far that has done nothing. The "flickering" is pretty severe on my screen. Only affects D3 - YouTube, etc. run perfectly fine. Running OS 10.9.5. Trying scan and repair now. Cross yer fingers.
    Running OS X 10.9.5.
    There's a Mac Technical Support forum here:
    https://us.battle.net/forums/en/d3/5386228/
    You might want to try posting there.

    There's warnings all over the Europe forums I follow that OS 10.9 is no longer supported by Blizzard... I haven't seen that notice on the US Mac forum yet, but that was implied somewhat in this post for another issue: https://us.battle.net/forums/en/d3/topic/20755055455#post-2

    Example of "End of support notice" : https://eu.battle.net/forums/en/d3/topic/17617603554

    Good luck !
    Worked for me :) For now at least :)

    Join the Conversation

    Return to Forum