Unexpected error when trying to launch Diablo

Technical Support
I'm getting an unexpected error with the following code when I try and launch the game: D5603C27-05AA-4201-90A3-74CD2F4DC9AE

I have run a scan & repair and not found any issues. What is this error and how could/should I resolve it?
Do you have an AMD card? Are you using drivers version 17.12.1? Do you have Windows 10?

Not 100% sure any of those are relevant, but I upgraded my AMD drivers yesterday and the game systematically crashes with that error since. It has to be that... on a specific card maybe? I have a R9 380.

EDIT: Actually my crash report has ID: 171C3911-F22F-4D5E-A0DB-10713E183DDC

EDIT2: I saw another post that said D3 32bit client crashes on startup so I switched to the 64bit client and that worked. I'm not to happy about that because I've had performance issues with the 64bit client before. I guess now's the time to figure out if I still have those issues because it's the only way to play the game at the moment.
@HopDevil
Can you post a DxDiag report?
I was playing fine this morning then exited to the character selection screen, alt-tabbed to Windows to check something, opened an OpenOffice document and tried to alt-tab back but couldn't get back to the game. I was not away for more than a few minutes so don't expect I had been logged out automatically. I have occasionally seen these screen freezes with the 64-bit client and to resolve them I usually ctrl-alt-del and sign out then sign back in and try again. This time when I tried again I got the cryptic error.
@Perfidy, I'm running an older NVIDIA GTX 860M card on Windows 10 with WHQL drivers that are definitely not the latest but they've been running perfectly for a long time and I don't upgrade them every other day.

@Zhyxen,

------------------
System Information
------------------
Time of this report: 12/17/2017, 17:23:07
Machine name: PC
Machine Id: {BAF0CFD8-D9A1-4D3F-8DB9-A0BD2B85BD58}
Operating System: Windows 10 Home 64-bit (10.0, Build 16299) (16299.rs3_release.170928-1534)
Language: English (Regional Setting: English)
System Manufacturer: ASUSTeK COMPUTER INC.
System Model: G551JM
BIOS: G551JM.204
Processor: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz (8 CPUs), ~2.5GHz
Memory: 16384MB RAM
Available OS Memory: 16268MB RAM
Page File: 2780MB used, 15918MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Supported
DxDiag Version: 10.00.16299.0015 64bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Display Tab 2: No problems found.
Sound Tab 1: No problems found.
Sound Tab 2: No problems found.
Input Tab: No problems found.

EDIT:
My NVIDIA control panel was not recognizing the GPU and the built-in Intel Graphics card took over. I disabled/enabled my NVIDIA driver through the device manager to get it to be recognized again and now everything appears to be back to normal.
@HopDevil
Can you try installing these drivers?
@Zhyxen,

I'm all set - see previous edit.
I am having the same issues: EB6539B1-9565-4EA1-B209-CBE334C5EC1E
@HopDevil
Glad you were able to get that figured out!

@Koraseru
Is your game also crashing at launch or does it occur while in-game? Would suggest starting out with the 17.12.1 AMD drivers here.

Join the Conversation

Return to Forum