icuin57.dll

Technical Support
Prev 1 26 27 28 29 Next
03/02/2018 02:39 PMPosted by Zuh
03/01/2018 02:29 PMPosted by DotSplat
try this till it's fixed
copied it from different post

1: Open Battlenet
2: To the right of where Diablo 3 is Located in the launcher, Click the "Options" Cogwheel
3: Select "Game Settings"
4: Select "Launch 32-bit client (instead of 64-bit)
5: Launch Game.


Worked like a charm for me. Thank you for the fix


This needs to be up-voted. This is a solution! Thank you!!
03/01/2018 02:59 PMPosted by DotSplat
03/01/2018 02:54 PMPosted by Jambrix
Hey all,

We are looking into this on our end. In the meantime if you're getting the error about missing icuin57.dll please try downloading and installing "Microsoft Visual C++ 2015 Redistributable Update 3" here:

https://www.microsoft.com/en-us/download/details.aspx?id=53840

yep, works, thanks
Did not work
Same here. :(
TO ALL: D/L THE x86 file and start the game in 32 bit mode, the x64 did not work for me, I run 64 bit win, but the 32 works!
So your 'game' requires something from Microsoft and you haven't included it as part of the download then? This sounds a lot like you making your bad choice our problem instead of actual help. Fix it on your end and push out the fix...if it's really THAT simple then it should take less than a day, yes?
Same here, worked fine yesterday and after Diablo update getting several missing ".dll" errors
They say all peeps can play all games now, well sorry folks but still get the same message for Diablo, error loading and I do not have a 32bit version of the game. So for me its 64bit or no game play
tried both 32 and 64 both have similar icuin57.dll errors...
same
I am running a dual boot config, windows 7 and 10. Both are 64 bit. I installed the latest patch in both yesterday. I can log into my Battle net account in both OS's, but, now I can't start Diablo in windows 10 (no problem in win 7). I get a pop up message:
Failure To Load

Critical Error During Loading Process

Required Library 'icuin57.dll does not exist'

I checked for the existence of this file in my win 10 Diablo folder and the file exists in two locations. Once in the main folder and once in x64 folder!

Maybe the patch has a bug in it that looks for the required file in the wrong folder now?

Any suggestions Blizzard?

**Update: I took the advice posted by Dotsplat and Jambrix and downloaded the Microsoft's Visual C++ update and installed it into my win 10 OS. Diablo now launches as it should. Thanks to you both for this info! Much appreciated.
this worked for me. thanks for the tip. You other guys should try it.
nothing is working fro me. tried every suggestions. vary frustrating
ditto
03/01/2018 02:04 PMPosted by Yeth
Restarted to apply update, playing fine beforehand, now error on launch says: Critical error during loading process; icuin57.dll does not exist.
Any suggestions?


I not only got that error message, but two prior to it,

MSVCP140.dll is missing from my computer and

VCRUNTIME140.dll is missing from my computer

And I uninstalled the game twice from my computer and it still will not let me play after the current installation as those error messages keep coming up :o(
I applied the C+++ patch and I still get errors starting Battlenet but if I just click OK on each of the errors Battlenet starts and then I can play the game with no issues
Same thing thing here
Failed to Load.

Critical error during loading process.

Required library 'icuin57.dll' does not exist.

---so, I cannot even get into and play Diablo III atm.---

***WoW & SCII are running fine.....
same happened yesterday tried today still happening.
after new patch update now getting a critical error required library icuin 57.dill does not exist, what do I do to fix?
03/02/2018 04:27 PMPosted by Warmachine

***WoW & SCII are running fine.....

Starcraft 2 wont work for me in 64b mode just like Diablo 3. It seems to be a problem with Blizzard and 64 bit systems.

Join the Conversation

Return to Forum