icuin57.dll Temp Work Around till fixed

Bug Report
Open launcher, click "Blizzard" in the top left corner >Click Settings>Click "Game Settings" in left side menu pane. Then in the Diablo III section (not the one labeled for PTR if you have that) click to check the "Launch 32-bit Client" option. Click "Done" and go play.
Or one could do this.
03/01/2018 02:54 PMPosted by Jambrix
Hey all,

We are looking into this on our end. In the meantime if you're getting the error about missing icuin57.dll please try downloading and installing "Microsoft Visual C++ 2015 Redistributable Update 3" here:

https://www.microsoft.com/en-us/download/details.aspx?id=53840
03/01/2018 03:49 PMPosted by kwittstruck
Or one could do this.
03/01/2018 02:54 PMPosted by Jambrix
Hey all,

We are looking into this on our end. In the meantime if you're getting the error about missing icuin57.dll please try downloading and installing "Microsoft Visual C++ 2015 Redistributable Update 3" here:

https://www.microsoft.com/en-us/download/details.aspx?id=53840


Did all of the above including trying to launch in 32bit , nothing works
I 2nd that. Does not work.
Worked for me. Had the same issue, downloaded Microsoft Visual C++ 2015 Redistributable Update 3 64bit onto a Windows 10 OS and could login after.
Application a 32 bit run well .
THK
Found a temporary work around, but the root cause still needs fixed.

Copy vcruntime140.dll and msvcp140.dll from your battle.net install directory (mine was C:\Program Files (x86)\Battle.net\Battle.net.9854) to your diablo 3 directory (mine was D:\Program Files (x86)\Diablo III). Once done, change your diablo three options to start the 32bit version: battle.net>diablo 3>options>game settings>launch 32 bit client.


This worked for me.
Did all of the above including trying to launch in 32bit , nothing works

Join the Conversation

Return to Forum