api-ms-win-crt-runtime-l1-1-9.dll and icuin577.dll does not exist

Technical Support
03/01/2018 10:55 PMPosted by fenris
critical error during loading process. icuin577.dll does not exist.

how do i uninstall the patch? game can't be loaded!
No, uninstall won't help. Try the blue post:
https://us.battle.net/forums/en/d3/topic/20761877245?page=3#post-54

Good luck.
03/01/2018 07:29 PMPosted by NaNaShi
api-ms-win-crt-runtime-l1-1-9.dll and icuin577.dll does not exist - missing dll after recent patch

Note: I already installed the "Microsoft Visual C++ 2015 Redistributable Update 3" and is currently running in x86 mode.

Please advice.

Install additionally Update for Universal C Runtime in Windows
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
i am having same issue crit error when loading d-3
same issue for me, after today update it could not start with erro message of ICUIN57.DLL DOES NOT EXIST.
already tried reinstall it but still same.
mine startcraft 2 work no problem only D3.....
please help.
03/02/2018 02:56 AMPosted by Homix
hey u all
try this solution
worked for me

https://us.battle.net/forums/en/d3/topic/20761877245?page=3#post-54

does not work for me...
Done all of previous advised instruction, no joy, getting "api-ms-win-crt-runtime-l1-1-0.dll and icuin57.dll"...

As mentioned,
-Drivers fully updated, and
-have run "Microsoft Visual C++ 2015 Redistributable Update 3"
A friend of mine had this problem after the last patch. I pointed him to download https://www.microsoft.com/en-in/download/details.aspx?id=48145 and it worked.

Hope it works for you guys too!
03/02/2018 02:51 AMPosted by Buggi
03/01/2018 07:29 PMPosted by NaNaShi
api-ms-win-crt-runtime-l1-1-9.dll and icuin577.dll does not exist - missing dll after recent patch

Note: I already installed the "Microsoft Visual C++ 2015 Redistributable Update 3" and is currently running in x86 mode.

Please advice.

Install additionally Update for Universal C Runtime in Windows
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows

it is for win7 sp1 at least, i use win7 basic so can not update
I am 68 of age do not know much about PCs. But I do know that I am unable to play and I do not know how to fix problem
03/02/2018 06:28 AMPosted by KABAL
A friend of mine had this problem after the last patch. I pointed him to download https://www.microsoft.com/en-in/download/details.aspx?id=48145 and it worked.

Hope it works for you guys too!


This guy wins the internet... or at least he does for me...
Icuin57.dll error message...
03/02/2018 08:27 AMPosted by Sturm
Icuin57.dll error message...


03/02/2018 06:28 AMPosted by KABAL
A friend of mine had this problem after the last patch. I pointed him to download https://www.microsoft.com/en-in/download/details.aspx?id=48145 and it worked.

Hope it works for you guys too!


It work for Icuin57.dll too ( I guess :) )
SOLVED:

1.) Uninstalled Diablo 3
2.) Installed the following:
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
Microsoft Visual C++ 2015 Redistributable Update 3
https://www.microsoft.com/en-in/download/details.aspx?id=48145

3.) Reinstalled Diablo 3

Solution is not pretty but it did the job for me
03/01/2018 08:22 PMPosted by Zuvykree
Dasto - Reviewing your Dxdiag it appears your Nvidia drivers are also extremely out of date as well. I found your latest Nvidia driver for you [url="http://www.nvidia.com/download/driverResults.aspx/131441/en-us"]Here[/url]. For this one when you get to the installation options select: Custom (Advanced) -> Next -> Check: Perform a clean install and finish the install. You should restart the computer before you retest the game.

Thank you!


Thanks....finally got the c++ whatever to install after a very long hang. went n tried the vid drivers tho just lik you said n everything went down for video,,,gave up last night. today after a number of correction attempts was able to restore to previous point to bring video back up but had to reinstall c++ whatevers. able to successfully log into game but after a couple toon jumps heard odd error sounding buzz n everything froze....game n launcher both but rest of system unaffected. continuing to tinker...will not be attempting to update drivers again however. has been attempted in past always to same effect so i let sleeping dogs lie. havent been able to update system nor vid drivers in years but at least it works. researchig found has been issues with installing certain antivirus programs in particular orders causing this sort of oddity wit windows but, ill get to all that spaghetti, someday lol. thanks fer what help you were able to help wit tho. appreciate it.
03/02/2018 09:17 AMPosted by NaNaShi
SOLVED:

1.) Uninstalled Diablo 3
2.) Installed the following:
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
Microsoft Visual C++ 2015 Redistributable Update 3
https://www.microsoft.com/en-in/download/details.aspx?id=48145

3.) Reinstalled Diablo 3

Solution is not pretty but it did the job for me

THIS WORKED FOR ME TOO! Thank you!
None of the methods works for me. Please fix this bug faster
re;
03/02/2018 12:13 PMPosted by ewanmd
None of the methods works for me. Please fix this bug faster


id suggest giving them somethng to look at by;

03/01/2018 07:33 PMPosted by Zuvykree
Howdy!

Our developers are actively looking into this issue as we speak. I can attempt to help if the current [url="https://us.battle.net/forums/en/d3/topic/20761877258?page=1#post-3"]workarounds [/url]have not allowed you to play.

Can you post up your [url="https://battle.net/support/article/000012988"]Dxdiag [/url]for review? Copy and paste the dxdiag contents into your reply, then highlight all the text and select our code block icon </> to make it easier to review.

Thank you!
got to the instructions link n get that sys info for them

Join the Conversation

Return to Forum