Game not starting

Technical Support
Hey having a bit of trouble starting up D3. Keep getting the "application encountered an unexpected error" message after pressing the blue play button.
My code is: DAB82735-2C28-4CA1-8A7A-8751E6580584

The only thing I've tried is deleting the Blizzard cache but that did not help. Any ideas?

Thanks!
Howdy Kitteh7979!

The occurrence error you provided is reporting an Access Violation when the game is attempting to do something. In this case it's either a third party program conflict with something running in the background or a display driver issue(Outdated drivers).

I'd recommend the following steps:

Step 1) Make sure your display driver and all system drivers are updated. We offer a support article if you need help with this Here.

Step 2) Place the system in Selective Startup. Restart and retest the game.

If the issue continues copy and paste your Dxdiag in your reply. Make sure to highligh the Dxdiag contents and select the code block icon </> to make it easier to read.
Hey there folks, when I go to start the game from the desktop icon I get an error reading "\??\C:\program data\Agent\Agent.6082\Agent.exe" Incompatible with 64 bit version of Windows!

Please contact your software provider to see if 64 bit program..... etc etc!
See Blizzard's response to the same post here:
https://eu.battle.net/forums/en/d3/topic/17618721710
Hey all,

We've seen a large influx of players having crashes on startup and freezes in the past few days. It appears to have coincided with an Nvidia graphics driver update, specifically the 397.31 driver. We aren't completely sure this is the cause but the timing matches so we want to get information on it. If you're using this driver, can you try rolling back to a previous driver build and see if that fixes it? If it does, please let us know in the thread here.
same problem will try driver rollback
Same problem. Refuse to rollback drivers because every other game I've tried works perfectly fine.
I had 370ish version drivers, and figured I needed to upgrade them and bring them up to date. I have been having this issue regardless of the drivers version, I just installed diablo 2 and I Can't connect to battle.net on it either. It's only diablo Im having any issues with, both games wont function.

I can however run heroes of the storm perfectly fine, WoW and the majority of your other titles so this is explicitly a problem with Diablo as a whole. I don't know what is causing it, but I've tried everything to get both games to run. All of your solutions have been attempted, and none have yielded results.
Just found this in admin advents:

Faulting application name: Diablo III64.exe, version: 2.6.1.49508, time stamp: 0x5a98e93d
Faulting module name: nvspcap64.dll, version: 3.13.1.30, time stamp: 0x5aa7d03d
Exception code: 0xc0000005

Maybe that will help you to figure out whats is going on.
Edit - the driver bug introduced with 397.31 should now be fixed with more recent builds of Nvidia drivers. Disabling Nvidia Share remains a good troubleshooting step, but you should just need to update your drivers at this point instead of following the Display Driver Uninstaller instructions.

Werebear,

Based on the timing of your issue and that driver you're running you're possibly having a totally different problem, but I think I see the problem.

Faulting module name: nvspcap64.dll

That's a part of nvidia's streaming program (Nvidia share, previously shadowplay.) You can try disabling it and if that doesn't work, completely reinstalling your display drivers with Display Driver Uninstaller. In this case, I recommend making sure you get a driver version older than 397.31 until we figure out whether or not this is where the incompatibility lies.

    1. Download, but do not install the latest driver from Nvidia
    2. Download Display Driver Uninstaller from The Wagnard Mobile Forum (Click “Official Download Here” near the bottom of Wagnard's first post. It will automatically download)
    3. Run the Display Driver Uninstaller file you downloaded and “extract” it to desktop
    4. On your desktop, click “Display Driver Uninstaller” and run it. Do not run in safe mode.
    5. Click “Clean and Restart”
    6. After restart, install the driver that we downloaded above in step 1.

Join the Conversation

Return to Forum