Switch - Can't join friends

Console Discussion
Everytime I tried to join/invite my friends, it always show this error: "there was a problem joining the game"

I already change my ISP (i have 2 connection in the house). it's the same.

anyone else having the same problem?
Are you behind a router/firewall? If so, what kind?
same issue.however,I can join/invite friends if the game is host by others.
We had the same problem... first day we played at my house in the early afternoon, 2 switches on the same Wi-Fi and on-line play no problem. After going home for dinner, we couldn't invite/join each other while each at our houses. Both switches NAT-B, no problems with Splatoon.

The only way to play together was to join someone else on a quick game.

Then yesterday, my friend could join me, but I can't join him... oh the wonders...
Anyone who has any idea how to resolve this issue? This is very annoying.
I'm having the exact same issue.
My wife and I each have a Switch, each have a copy of the game, each have the Nintendo online service and are each on the same wi-fi network in my house.

We see each other online as friends, but 99% of the time if we invite the other or try to join the party we get the error joining game message.
Sometimes that will work. Sometimes it works if one of us starts a game and the other joins rather than doing it from the menu, but that's not always a guarantee.

Is this a legit issue, or am I missing something? Could router issues still come into play when we're both on the same network?
Guys can you all make a non season NS player & join each other game first see if there is any problem if you guys have no problem joining each other than it is likely a switch online problem which you should spam Nintendo

but if there is still a problem in NS I really dun know what to say just try it
I have a non-season character, and I have the exact same problem when I try to connect with my friends a few cities away (Netherlands). Sometimes it works, sometimes it seems to take several restarts and Switch reboots before we can get anywhere.

Usually when we have problems, they can see me in the startup screen but I cannot see them. They can only join me. Sometimes we can see each other and joining works both ways. Sometimes we see each other and joining fails with the same annoying error. It's very, very random.

I tried opening up all "Diablo 3" and "Blizzard Downloader" TCP ports as given here:

https://eu.battle.net/support/en/article/7842

Didn't work. After that I just opened all TCP ports to my switch, didn't work.

It might be that my friends have their router/firewall to tightly setup, but it feels like this is more a Blizzard/Nintendo online/Diablo server issue since it's so random.
Having this same problem. Played with my 3 friends once, last night, everything was fine. Today, no one can connect to each other. This is on the Switch version.
In having the same issue with my wife. Same wifi same router; 30% of the time we can play together, usually after restarting both switch consoles a couple of times.
Found this topic from years ago: https://gamefaqs.gamespot.com/boards/704530-diablo-iii/67204643

That reminded me I also have a 'media server' feature in my FRITZ!Box router. I checked it and it is default enabled. So I disabled it. Together with opening up all ports I'm hoping this might resolve it (however weird the fix is). When I have tested it I will post it.
I found the solution.
for those of you who still haven't solved this, try this out:
1. In your router, Port Forward. Open UDP Port 45000-65535 for the switch.
Don't forget to reserved static IP for your switch in the router, so you won't have to change the port forward setting for the next time, in case your switch change IP.

2. If above didn't work, disable it and try DMZ your switch connection.
Again, don't forget to set reserved IP for your switch.

at least for us these works.

Another solution you could try:
In Diablo Switch. Change your connection privacy from friends to global/public.

Also try this one:
Go to setting, multiplayer, change your region to all/none, and uncheck all of the option below it. Basically disable all of the restriction.

Another thing to note:
If you set your switch to sleep while still in the game. the next time you play, go to the first menu where you have to "Press any button to start" (not lobby).
If it didn't work, close it and restart the game.
Nice! Thanks for the info. I'll look into the restrictions soon.

I opened all ports, disabled the Fritzbox mediaserver and my friend enabled xbox mode on his router (has to do with similar conflicts on the xbox). It seems to work better, but not always. I think this might be related to sleep mode too, so usually a restart of the switch works for me in this case.

I also noticed that it is possible that if 1 way of joining doesn't work (f.e. you joining your friend), the other way does (so your friend can join you). It seems that after he joined, you can join his.

Still vague problems, but a little less than without changing the router settings. So blizzard has some work to do regarding sleep mode and multiplayer if you ask me.
I ran into this problem myself and it's pretty frustrating. After trying pretty much everything listed here, I was able to get reconnected after I erased the connection info on my switch and then set it back up again. On the router end, I did set a manual IP for my device, but didn't go through with any port forwarding or DMZ settings - so maybe just getting a new IP address fixed it.

Edit - problem returned randomly after leaving a game with a friend I was not able to search quick match and now unable to join anyone else. Previous fix is not helping so I'm not sure what to try next
Does anyone already have a solution to this problem?

Until last week i didn't have any problems, now i can't join friends and the quick mode option is gone as well.

Already tried all of Zervos methods, none of them worked.

And for the record: i have a nintendo online subscription and all my other games work just fine.
Still unfixed
I am having the same problems and I tried all of the solutions list on the forums. We have 3 Switches in the house, on the same WiFi and 1 of them can't connect online.
I'm still unable to connect to friends..
Same issue for me, blizzard fix it
I, like everyone on this thread cannot connect to my friend who show up online in Diablo and can send the invite, they get the pop up but ends in the same error. I have tried every possible suggestion on this thread and others but no luck. Not to mention we shouldn't have to make detailed technical adjustments in order for this to work.

I have tried port forwarding, DMZ mode, changed MTU size but the same error occurs. We are both subscribed to Nintendo Online and have played together on other consoles with to issues and other Nintendo online games work fine.

With such a big announcement and focus on the Switch lately I would have expected a quicker reaction to this issue.

Anyone have a solution besides "you both need to be subscribed"

Join the Conversation

Return to Forum