(Switch) Can't do multiplayer

Console Bug Report
I'm online and connected to Diablo network, have the Nintendo online subscription, and have my network settings set to online. The lobby view on the pause menu shows a symbol with an X over it with the text "Local Only". I can see my Online Friends, but trying to join them gives me the message "There was a problem joing the game." They say that I do not show up in their online friends list in game. My roommate can do multiplayer just fine on their switch though. I've tried deleting and redownloading the game and exiting the game and starting back up but it does not help.

Please help me solve this issue!
I posted this same problem a day ago.
it seems like a lot of people are reporting this and they have not replied yet :(
Have you checked your game privacy settings as well? By pressing (+) on the Main Menu, you might have setup them up for Local only by mistake.

So please check your game Privacy settings as well to ensure it's open to friends etc.

Another thing you might want to check on the Switch itself that I've already seen people reporting issues with it, is the clock on the Switch.

Make sure the clock of the Switch is showing the correct time and if not, go to Settings and ensure you select the option to download the time/date information from the internet instead of manually set. Since if you have the clock of the Switch wrong it has been reported to cause issues with Diablo Servers. (I.E people were unable to receive season gifts but as soon as they fixed the clock it allowed them to retrieve the gifts).

If your roommate can play just fine and since he is your roommate, I'm guessing you are both connected to the same network and router, so this shouldn't be an issue from your Network or Router configurations such as port forward etc.

If any of you wanna test this out we can go on Discord or whatever and we try to see what's wrong or if there is indeed an issue here.
terrible questions:
1) How do you create "friends" for online play?
2) How do you search for people to play online?
3) How do you send invitations to people online?
Has anyone found a solution yet? It's infuriating.
Same here.. it's getting frustrating.
Same issue. Have tried everything under the sun.
Both my brother and I have Nat type A
I have set my switch to DMZ under router settings, he has forwarded ports.

We were able to play last night after trying to connect to each other a handful of times. Stopped playing, couldn't connect later in the night. We were able to reconnect once today, his wifi went down for a minute, could not reconnect .

We have tried:
Restarting consoles
Changing match settings from friends only to public
Switching from local multiplayer back to online
Deleting wifi settings on switch and re-adding

We can connect to other people's games via quick match (when we can find one) and then invite each other and play that way, although doing that has resulted in either being booted when the host leaves or it being very laggy. When the host leaves and it migrated to a new host we both get bumped into our own games.

This is getting ridiculous, it is obviously not a Nintendo side error as Blizzard seems to suggest in other posts I've seen them respond to as we can play no problem in other games, Mario party, Mario Kart etc.

Fix the bloody game
Same here. Was able to play in the hotel I was staying at yesterday with my bro who was hundreds of miles away but at home we can't. "There was a problem joining the game."
I managed to solve this issue last night by using Speedify as a VPN on my laptop, and shared it over Connectify over to my Switch. I couldn't connect to my brother still but he could connect to my game. I think you should be able to use any other type of VPN, but Connectify had a specific "gaming mode" with the Nintendo Network setting. Maybe thats what made it possible.

I tried connecting with a different VPN and connecting my switch to my Windows 10 default Hotspot but I couldn't share the VPN network (IP on Switch still displaying my local IP). If someone with better knowledge can help me out on this cheaper fix thank you!
We also experience same issue... did you guys find a solution to fix this issue? its already march lol
Been trying to find ideas to fix this issue, posted to blizzard no answer. at this point man, this is a lost cause.
03/03/2019 06:24 AMPosted by BossJhiggs
We also experience same issue... did you guys find a solution to fix this issue? its already march lol


nope
Are you guys paying for Nintendo Switch Online? You know you have to pay for that right? Family bundle is best just get 8 friends to join for much cheaper per year
The problem is on blizzards side. Their interface with the nintendo switch friends list is bugged. You may have no problems with connecting to friends, or you can see them but not connect, or you can't see them at all. These are the complaints I've seen and they all lead back to blizzards interface with the switch friends list. In my case I'm in the US trying to play with my friend in Japan. I can't see them on my friends list, but I can join them in quick match. Our switch accounts are linked to blizzard and microsoft. We have our nintendo online subscriptions and our routers are forwarded and NAT type A. It's obvious that everything is working except for the d3 friends list interface otherwise we wouldnt be able to play on quick match. So as soon as blizzard stops blaming everything else but themselves and get to work on the real problem (instead of acting like EA) maybe this will be resolved.
I had this same problem since the game was released. Finally figured it out through a lot of trial and error.

Follow these steps:
1) Go to the router settings from your computer
2) Go to your Wireless Settings
3) Go to Access Control
4) Click to show all your currently connected devices
5) On your Nintendo Switch: Go under system settings- Internet.
6) Take a look at your System MAC Address and match the number with your Currently Connected Devices on your computer.
7) Beside the System MAC Address that matches your Nintendo Switch click on Manage Device
8) Click NO for Managed Device

This allowed me to connect instantly on Diablo 3.
Is the issue resolved? I spent 2 hours trying all sorts of ways to connect and it still doesn't work for me. I can't even see the Quick Match option. I can see my brother online (he can't see me) but every time I try to join, an error message pops up.

Blizzard still seems to only link to Nintendo and I can't open a ticket. I can play any other online game (Smash, Warframe, etc) just fine, it's only Diablo 3 that's giving me problems. I can't even find a way to ask for a refund anywhere... I bought the game to play with my brother but it just won't.
I have tried many things. Port forwarding, forcing DNS, UPnP, Managed device (which is router specific), different bands, having my friend try to join me, me trying to join my friend, my friend trying to join me in a quick play, public, friends only, invite only, and read upwards of 20 threads at this point.

Blizzard, this is not a simple problem, it probably requires a hard solution. Please, please let me play this game with my friend on the other side of the country.
I also tried all sorts of things and it's clear that it is not an isolated issue. It's kinda infuriating that there is no simple or direct answer about that.
From experimenting with my wife's and my own switch it seems like a problem with both devices trying to set up the same UDP port forwarding rule via UPnP. It could be easily solved if the game let you choose a different UDP port to use in the settings somewhere. Local play works for us, but we were really hoping to be able to play in different rooms on different TVs.

Join the Conversation

Return to Forum