Diablo 3 Switch Multiplayer?

Technical Support
I was trying to play online with 3 of my friends, who all were able to get online without too many problems, but for some reason, I was unable to join them and was repeatedly told by the game that I could not join their party. In addition, I simply do not have the option to invite them to form a party, and my quick match mode is also non-existant as well.

Please don't tell my that I need Nintendo Switch Online as I already have it. I have also tried turning my switch on and off 5 times, uninstalling, taking the cartridge out, etc.

I got this game almost solely to play with my friends, so if anyone is in a similar situation and has a better idea of what to do, please let me know.
i got the error "there was a problem joining the game" everytime i tried join/invite my friends
I’ve had the exact same problem, I can’t get out of local play. I have a subscription and everything just like you said. No quick match option at all. Super frustrating and it seems like no one has answers for it.
I am also unable to get this to work. (And yes I purchased on online account with Nintendo) Blizzard technical support points to Nintendo. Nintendo support doesn't know what's going on at all and are completely clueless.

Please advise.
I'm also having this issue, can't play with anyone right now. Was working just fine last night.
Same as my friend and I, and we just bought a Nintendo online sub and did play the free NES games online.

This issue is widespread and many reddit users have it too, keep pushing so this gets fixed, otherwise they'll sleep on it.

https://eu.battle.net/forums/en/d3/topic/17624523370?page=1#post-3
I am having the same issue. I cannot join any of my friends in Diablo. Sometimes, it will randomly work. I am only having this issue in Diablo. I play other online games fine on the Switch.
Yea, having the same issue here as well. I have an open NAT and ports forwarded for my switch but still can't play with my friends.
I am having the exact same problem with one of the 3 switches in my house. 2 Switches can get online and the other can not. I have verified all the settings and reset the console with no luck.

The Game Privacy mode resets itself to Invite Only.
I had this same problem since the game was released. Finally figured it out through a lot of trial and error.

Follow these steps:
1) Go to the router settings from your computer
2) Go to your Wireless Settings
3) Go to Access Control
4) Click to show all your currently connected devices
5) On your Nintendo Switch: Go under system settings- Internet.
6) Take a look at your System MAC Address and match the number with your Currently Connected Devices on your computer.
7) Beside the System MAC Address that matches your Nintendo Switch click on Manage Device
8) Click NO for Managed Device

This allowed me to connect instantly on Diablo 3.

Join the Conversation

Return to Forum