Cursor not working

Mac Technical Support
I am not able to move the cursor on my game.
Howdy Achilles,

Are you currently playing on a Windows or Mac OS?
12/13/2018 03:20 PMPosted by Joynueer
Howdy Achilles,

Are you currently playing on a Windows or Mac OS?
mac
12/13/2018 03:23 PMPosted by tARO
12/13/2018 03:20 PMPosted by Joynueer
Howdy Achilles,

Are you currently playing on a Windows or Mac OS?
mac
same issue here too btw.
Howdy Taro,

For mac there is currently a bug causing mouse issue with playing in Fullscreen, lets try the following step to see if it fixes the issue.

Launch D3, once the game is open try the following Keyboard shortcut:
Control + M to switch to Windowed.
12/13/2018 03:25 PMPosted by Joynueer
Howdy Taro,

For mac there is currently a bug causing mouse issue with playing in Fullscreen, lets try the following step to see if it fixes the issue.

Launch D3, once the game is open try the following Keyboard shortcut:
Control + M to switch to Windowed.
ok allow me to try this and ill reply back in a few as it takes a while to launch off
12/13/2018 03:28 PMPosted by tARO
12/13/2018 03:25 PMPosted by Joynueer
Howdy Taro,

For mac there is currently a bug causing mouse issue with playing in Fullscreen, lets try the following step to see if it fixes the issue.

Launch D3, once the game is open try the following Keyboard shortcut:
Control + M to switch to Windowed.
ok allow me to try this and ill reply back in a few as it takes a while to launch off
ok it seems to be working now on a small screen. I'm used to full screen.
Hey hey tARO,

I'm glad to hear it worked. You should be able to make it fit most of the screen by maximizing it. But hopefully the bug will be fixed soon so you can go back to playing at Fullscreen.
12/13/2018 03:36 PMPosted by Joynueer
Hey hey tARO,

I'm glad to hear it worked. You should be able to make it fit most of the screen by maximizing it. But hopefully the bug will be fixed soon so you can go back to playing at Fullscreen.
ok thanks
I had the exact same problem on MAC, Mojave 10.14.2. Worked great until the latest update, now only works in the small screen mode.
@Rich, @tARO,

Two things...

1) Once D3 is running on the small screen mode, you can go in D3 Options, under video, and change display to Fullscreen(Windowed). Don't change it to "Fullscreen" because it's going to lock up your mouse again.

2) There is also a workaround that will allow you to play "Fullscreen"... it is covered here: https://us.battle.net/forums/en/d3/topic/20743745904#post-15
12/11/2018 06:59 PMPosted by Ivan
If you go to Preferences -> Security & Privacy -> Accessibility and enable it for Diablo III, the cursor starts working again in full screen.
and, in more details, in the post just under it:
12/11/2018 08:06 PMPosted by ingy
The frozen cursor problem seems peculiar to the Apple computers, and Ivan's solution works except brevity of his suggestion confused me at first - perhaps it's because I am a computer novice. The remedial procedure (at least to me) is:
System Preferences -> Security & Privacy -> Privacy (if not chosen already) -> Click to unlock to make changes (lower left) -> Click Accessibility (left), Diablo III.app (right)
After the changes, one should make sure that the changes are in force by looking at System Preferences again.
I'm experiencing this problem as well with frozen mouse cursor in fullscreen mode on macOS. Any ideas when this will be fixed?
12/13/2018 03:25 PMPosted by Joynueer
Howdy Taro,

For mac there is currently a bug causing mouse issue with playing in Fullscreen, lets try the following step to see if it fixes the issue.

Launch D3, once the game is open try the following Keyboard shortcut:
Control + M to switch to Windowed.


It works for me, but I want to play fullscreen, it stop working when I go back to full screen, and it's cmd M, not ctrl M
Seems to be something related with the last patch. Before the update was working fine.
my cursor does not work please advise
12/13/2018 06:22 PMPosted by Boubou

2) There is also a workaround that will allow you to play "Fullscreen"... it is covered here: https://us.battle.net/forums/en/d3/topic/20743745904#post-15
12/11/2018 06:59 PMPosted by Ivan
If you go to Preferences -> Security & Privacy -> Accessibility and enable it for Diablo III, the cursor starts working again in full screen.
and, in more details, in the post just under it:
12/11/2018 08:06 PMPosted by ingy
The frozen cursor problem seems peculiar to the Apple computers, and Ivan's solution works except brevity of his suggestion confused me at first - perhaps it's because I am a computer novice. The remedial procedure (at least to me) is:
System Preferences -> Security & Privacy -> Privacy (if not chosen already) -> Click to unlock to make changes (lower left) -> Click Accessibility (left), Diablo III.app (right)
After the changes, one should make sure that the changes are in force by looking at System Preferences again.


@Boubou Thanks! This worked.

For Blizzard, I'm guessing here, but it's probably related to the "Disable OS Keyboard Shortcuts" option for Mac Users, as that option is automatically enabled in Full Screen mode. It's hard to test because I can't disable OS Keyboard Shortcuts in windowed mode and not allow access, but the two seem related. Hope this helps. Apple probably changed something in their latest patch that prevents Diablo from automatically enabling the option in Full Screen mode. Thank you.
Well, I'm glad it's not just me. Looking forward to a fix.
Same problem here, will try Ivan's suggestion as well.

Also running on Mac. Will post after I try it.
The Ctrl+M fix only addresses the cursor issue but now there is a game memory issue as well with Season challenge progress. I wonder why Blizz has not addressed these problems in the forum yet - it's been 2-3 days now. Also there was a small patch and restart of the Client but this had no effect.
Windowed full screen works for me.

Join the Conversation

Return to Forum