Cursor not working

Mac Technical Support
12/13/2018 03:01 PMPosted by Achilles
I am not able to move the cursor on my game.
Marked As Solution
Be sure to try the steps provided in the thread. This is similar to the Heroes of the Storm and Starcraft II issue where the game needs Accessibility permissions for the mouse to work in Fullscreen mode. You can do this by setting the game to windowed with Command + M. From there toggle the Disable OS Keyboard Shortcuts option. This should prompt you for permissions.

You can also go to the Security & Privacy settings on the Mac. From there go to Accessibility and make sure the game is checked if it shows up.
This did not resolve the issue for me. This cursor reverts back to a larger variation that is locked in position in full screen still.
I restarted the game once more after making the security changes and the issue was resolved. Thank you.
12/16/2018 05:13 AMPosted by zestytaco96
12/13/2018 03:01 PMPosted by Achilles
I am not able to move the cursor on my game.


12/16/2018 08:38 AMPosted by Zhyxen
Be sure to try the steps provided in the thread. This is similar to the Heroes of the Storm and Starcraft II issue where the game needs Accessibility permissions for the mouse to work in Fullscreen mode. You can do this by setting the game to windowed with Command + M. From there toggle the Disable OS Keyboard Shortcuts option. This should prompt you for permissions.

You can also go to the Security & Privacy settings on the Mac. From there go to Accessibility and make sure the game is checked if it shows up.
SORRY BLIZZARD.......DOES NOT WORK!!!!!!!!!
Please spend a little extra time to find out what the problem is and possible give it a fix on your end........
New iMac, arrived yesterday. macOS 10.14.2. Same issue with stuck cursor in fullscreen, enabling Accessibility for the Diablo III app solved the issue for me. Hacky slashy fun times in my Magic Pants.
I had the same problem, and the accessibility thing worked fine, but now effects are pixelated, and the game locks up randomly
I have this problem with a Mac Pro running Mojave, whether using wireless trackpad or USB mouse. The settings modifications to Security in System Prefs didn't fix it.

It DID fix it on a MacBook Air running Mojave.
This solved the problem on Mac book pro, running Mojave.
Thank you!
I am also having the same mouse problem on an iMac. As soon as I updated to Mojave 10.14.2 my mouse would lockup when the game started. Very frustrating. I am going to try it in windowed mode but am really hoping for a quick fix. I am sorry everybody here has the same problem but I am glad it is not just me.
My not working too :/
If I set accessibility option, mouse is working but its moving too slow :(
Im using touchpad.
Yup, Blizzard f@#ked up with latest update. The below instructions work except for iMac, not Windows, use Command +M to switch window modes. Ctrl +M cuts Music off/on !!!

Posted by ingy
The frozen cursor problem seems peculiar to the Apple computers, and Ivan's solution works except brevity of his suggestion confused me at first - perhaps it's because I am a computer novice. The remedial procedure (at least to me) is:
System Preferences -> Security & Privacy -> Privacy (if not chosen already) -> Click to unlock to make changes (lower left) -> Click Accessibility (left), Diablo III.app (right)
After the changes, one should make sure that the changes are in force by looking at System Preferences again.
FWIW, I can work around this, now, by plugging in headphones. That solves for me.
The headphone trick doesn't always work for me. :(
Is this not going to be handled? I can play with headphones on my MacBook Air 11" but not on my 6 core 3.5GHz Mac Pro? Brutal.
Additional fix:

In your mouse software, reduce the polling rate (reports per second) below 1000. I switched the polling rate on my new Logitech G502 from 1000 to 500, and that fixed the problem for me.
Hey folks,

Sorry for the silence on this, this should have been fixed in Mac OS 10.14.4 and later. If you have not updated to 10.14.4 or later, please do so now.

Please be aware that we had to work with apple on this. The fix is at the Mac OS level so it is not retroactive for earlier versions.
I am having problem again in fullscreen mode. I have tried everything. I am running Mac OS 10.14.5. Now what. I do not like playing in smallscreen mode. It regularly grabs the edge and resizes the window right in the middle of battle.

05/04/2019 04:00 PMPosted by Drakuloth
Hey folks,

Sorry for the silence on this, this should have been fixed in Mac OS 10.14.4 and later. If you have not updated to 10.14.4 or later, [url="https://battle.net/support/article/31024?utm_source=internal-TechForum&utm_medium=posting&utm_campaign=BlizzardCS&utm_content=solution"]please do so now[/url].

Please be aware that we had to work with apple on this. The fix is at the Mac OS level so it is not retroactive for earlier versions.

Join the Conversation

Return to Forum