Mouse cursor frozen (iMac)

Mac Technical Support
After the recent update (~1hr ago), the mouse cursor is frozen. The mouse moves until the connecting screen. After that it is frozen. Keyboard works. On screens where the cursor is above something, the item beneath does light up and I can click it.

If I place the cursor over the 'resume game' button and click, the game attempts to load but is frozen.

I was playing before the update with no problem.
Just happened to me also.. Had to do a hard reboot
Will try again. :(

--> UPDATE..
Mouse froze again, before being able to click play..
Can't play Diablo now! :(
I'm having the same problem. Why, Blizzard, why?

I was playing Diablo 3 late morning and all was well. I just updated about 10 minutes ago and the cursor will not move. I thought maybe my wireless mouse's batteries died. I put in new batteries and it still didn't move. Placed Diablo 3 in window mode (Command-M) and I was able to move the cursor within the game. Command-M again to get it to full screen and cursor will still not move. Only in window mode will the cursor move.

Looks like I will have to wait for the next update. >:-O

MacPro5,1
Mojave 10.14.2
Radeon RX570 8GB RAM

--->Robert
8-)
Same issue. No cursor movement, can click.
Same. MBP 2018 MacOS 10.14.1. Diablo 2.6.1.55235. Was working fine earlier today, I assume before this latest patch. Have rebooted, still same.
Has anyone contacted Blizzard using the ticket system ?
https://us.battle.net/support/en/help/product/diablo3/273/279/channels

or Twitter ?
https://twitter.com/BlizzardCS

Any volunteers ???

This problem is also being reported in Technical Support and Bug Report forums... :(
Same here, can't play in fullscreen... Windowed mode only... Seriously Blizzard?

iMac16,1
Mohave 10.14.2
Starting in either Windowed or Windowed(Fullscreen) appears to be some sort of a workaround...
12/11/2018 03:44 PMPosted by Aesopea
Same here, can't play in fullscreen... Windowed mode only
12/11/2018 03:32 PMPosted by Smile
Well, I've run diablo in window mode (-w) and changed Display mode to "Windowed(Fullscreen)" and works fine.

The problem exists only in fullscreen mode.
https://us.battle.net/forums/en/d3/topic/20770546953#post-6
Yes, windowed mode looks like it would work, but switching back to full screen always locks the mouse cursor.
BouBou your fix worked for my on my iMac thanks!
12/11/2018 06:35 PMPosted by Lytebrynger
BouBou your fix worked for my on my iMac thanks!
Great.... but it's not my fix.... I'm just the messenger bringing the good news. :)

----------------------------
Edit : More news... from Europe https://eu.battle.net/forums/en/d3/topic/17625512427#post-2

If you go to Preferences -> Security & Privacy -> Accessibility and enable it for Diablo III, the cursor starts working again in full screen.
Same problem here. This problem happened in Starcraft, so I went over to Diablo. Now it seems to have percolated over to this game.
I'll take it as a sign that I need to do something else besides play Blizzard games. Thanks for the fun. It really was a blast.
Same problem here... I can only play in window mode; before yesterday patch everything was fine
Same with me, mouse cursor moves in windowed mode, but not in fullscreen. Bf on Windows not affected!
12/12/2018 07:34 AMPosted by deadteddys
Same with me, mouse cursor moves in windowed mode, but not in fullscreen. Bf on Windows not affected!
See the 2 quotes below...

https://eu.battle.net/forums/en/d3/topic/17625512427#post-2
If you go to Preferences -> Security & Privacy -> Accessibility and enable it for Diablo III, the cursor starts working again in full screen.


https://us.battle.net/forums/en/d3/topic/20770546953#post-17
12/11/2018 07:45 PMPosted by Curadh
Here's the response I got back from opening a ticket and it works.

These steps may help with this issue:

Hit Command + M to go into Windowed Mode.

Go to System Preferences > Security & Privacy > Privacy > Accessibility. Check Diablo III.

Go into Windowed Mode
Options > Mac Users
Check Disable OS Keyboard Shortcuts


Good luck !
If you go to Preferences -> Security & Privacy -> Accessibility and enable it for Diablo III, the cursor starts working again in full screen.


That did the trick. I now have cursor movement with my mouse in full screen.

I wonder if the update caused it to reset the Preferences > Security & Privacy > Accessibility?

--->Robert
8-)
12/12/2018 07:34 AMPosted by deadteddys
Same with me, mouse cursor moves in windowed mode, but not in fullscreen. Bf on Windows not affected!
See the 2 quotes below...

https://eu.battle.net/forums/en/d3/topic/17625512427#post-2
If you go to Preferences -> Security & Privacy -> Accessibility and enable it for Diablo III, the cursor starts working again in full screen.


https://us.battle.net/forums/en/d3/topic/20770546953#post-17
12/11/2018 07:45 PMPosted by Curadh
Here's the response I got back from opening a ticket and it works.

These steps may help with this issue:

Hit Command + M to go into Windowed Mode.

Go to System Preferences > Security & Privacy > Privacy > Accessibility. Check Diablo III.

Go into Windowed Mode
Options > Mac Users
Check Disable OS Keyboard Shortcuts


Good luck !
Blizzard uses the 3-letter word :-P

12/13/2018 03:25 PMPosted by Joynueer
Howdy Taro,

For mac there is currently a bug causing mouse issue with playing in Fullscreen, lets try the following step to see if it fixes the issue.

Launch D3, once the game is open try the following Keyboard shortcut:
Control + M to switch to Windowed.


12/13/2018 03:36 PMPosted by Joynueer
Hey hey tARO,

I'm glad to hear it worked. You should be able to make it fit most of the screen by maximizing it. But hopefully the bug will be fixed soon so you can go back to playing at Fullscreen.
12/11/2018 03:44 PMPosted by Aesopea
Same here, can't play in fullscreen... Windowed mode only... Seriously Blizzard?

iMac16,1
Mohave 10.14.2
Seems to work if you put it on windowed fullscreen mode at options.
Locking this thread, so we can focus the mouse cursor issue on one thread. Please try the workaround on this post.
12/16/2018 08:38 AMPosted by Zhyxen
Be sure to try the steps provided in the thread. This is similar to the Heroes of the Storm and Starcraft II issue where the game needs Accessibility permissions for the mouse to work in Fullscreen mode. You can do this by setting the game to windowed with Command + M. From there toggle the Disable OS Keyboard Shortcuts option. This should prompt you for permissions.

You can also go to the Security & Privacy settings on the Mac. From there go to Accessibility and make sure the game is checked if it shows up.

Join the Conversation

Return to Forum