What's going on with the servers?

General Discussion
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.
01/25/2019 01:30 PMPosted by Gimpzor
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.


Ive had a few issues but all in mega pulls in 4 man pushes...no issues in solo play or standard 4 man content such as t13 rifts or speed grs
01/25/2019 01:30 PMPosted by Gimpzor
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.


Yes, they are aware there is some lag and have been discussing it. I have not heard anything back though. Current theories from players here:

-Pain Enhancer gem may be causing interrelations. Try with and without it.
-Other spell combos causing some sort of lag?
-Server load due to new season?

01/25/2019 01:37 PMPosted by XS3NIGMA
Ive had a few issues but all in mega pulls in 4 man pushes...no issues in solo play or standard 4 man content such as t13 rifts or speed grs


This is what I am hearing as well - that it ends to be high GRs with multiple players.
01/25/2019 01:48 PMPosted by MissCheetah
01/25/2019 01:30 PMPosted by Gimpzor
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.


Yes, they are aware there is some lag and have been discussing it. I have not heard anything back though. Current theories from players here:

-Pain Enhancer gem may be causing interrelations. Try with and without it.
-Other spell combos causing some sort of lag?
-Server load due to new season?

01/25/2019 01:37 PMPosted by XS3NIGMA
Ive had a few issues but all in mega pulls in 4 man pushes...no issues in solo play or standard 4 man content such as t13 rifts or speed grs


This is what I am hearing as well - that it ends to be high GRs with multiple players.


Hey MissCheetah. 4 Man groups are indeed the worst especially when trying to push. However we are noticing issues when key farming solo, and groups as well. Even when sitting in town, sometimes the latency is just randomly jumping. When connected to an east coast server I am usually 30-50 ms, and roughly the same for the players I play with. However now east coast servers seem to be jumping to random high latency. It's almost like there is a routing issue somewhere in there route. I remember this happening a couple year ago, and there was an ATT server they were using that had some bad ports in the switches. Not sure if this is the case again, as I havent trace route, or pathpinged yet, but it does feel very similar to when that issue was going on.
01/25/2019 01:30 PMPosted by Gimpzor
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.


Few players are on this season. So you guess if it was a great season with new content 3x more players. So the server would get off.
I also experience a lot of rubberbanding with my DH on US server.
Wasn't so bad during S15.

Btw I play from EU where I have my main account.
Server spikes in lag have been unreal between yesterday and today US east coast
01/25/2019 02:11 PMPosted by Gimpzor
When connected to an east coast server I am usually 30-50 ms, and roughly the same for the players I play with. However now east coast servers seem to be jumping to random high latency. It's almost like there is a routing issue somewhere in there route. I remember this happening a couple year ago, and there was an ATT server they were using that had some bad ports in the switches. Not sure if this is the case again, as I havent trace route, or pathpinged yet, but it does feel very similar to when that issue was going on.


There are no East Coast servers :) Not kidding. The North Americas server for us is in Los Angeles, CA. So you are right, there also could be a routing issue impacting some people on some ISPs. The AT&T one you reference is just one example of it happening before.

This could turn out to be multiple things causing it!
01/25/2019 02:55 PMPosted by MissCheetah
01/25/2019 02:11 PMPosted by Gimpzor
When connected to an east coast server I am usually 30-50 ms, and roughly the same for the players I play with. However now east coast servers seem to be jumping to random high latency. It's almost like there is a routing issue somewhere in there route. I remember this happening a couple year ago, and there was an ATT server they were using that had some bad ports in the switches. Not sure if this is the case again, as I havent trace route, or pathpinged yet, but it does feel very similar to when that issue was going on.


There are no East Coast servers :) Not kidding. The North Americas server for us is in Los Angeles, CA. So you are right, there also could be a routing issue impacting some people on some ISPs. The AT&T one you reference is just one example of it happening before.

This could turn out to be multiple things causing it!


I heard a while back that they implemented servers on the east coast.. However since you're saying that's incorrect, and all servers are on the west coast, how come some I connect to give me my usual 30-50 ms, while others are a constant 100-115ms? Just newer servers for the ones that are giving better latency?
Unplayable right now with the input lag and rubberbanding in HC.
I get frequently disconnected and just in the middle of GR :(
I wish Blizzard would seperate from Activision, it is ruining their reputation :(
01/25/2019 03:03 PMPosted by Gimpzor
I heard a while back that they implemented servers on the east coast.. However since you're saying that's incorrect, and all servers are on the west coast, how come some I connect to give me my usual 30-50 ms, while others are a constant 100-115ms? Just newer servers for the ones that are giving better latency?


I don't have a complete answer to that ...that I can share publicly. There have been a lot of changes to the networking infrastructure within Blizz and their data centers. I don't have the details of it nor the authority to talk about it. I can say for sure though there are no servers for any Blizzard games on the East Coast right now. There never was for D3 and for WoW it got moved many years ago. The closest is the Chicago Data center but they don't do D3 from that.
01/25/2019 04:21 PMPosted by MissCheetah
01/25/2019 03:03 PMPosted by Gimpzor
I heard a while back that they implemented servers on the east coast.. However since you're saying that's incorrect, and all servers are on the west coast, how come some I connect to give me my usual 30-50 ms, while others are a constant 100-115ms? Just newer servers for the ones that are giving better latency?


I don't have a complete answer to that ...that I can share publicly. There have been a lot of changes to the networking infrastructure within Blizz and their data centers. I don't have the details of it nor the authority to talk about it. I can say for sure though there are no servers for any Blizzard games on the East Coast right now. There never was for D3 and for WoW it got moved many years ago. The closest is the Chicago Data center but they don't do D3 from that.


I wonder if the information that you can't disclose is the difference between to 10+ year old servers and the other new(er) servers they have.
I haven't experienced any lag or stuttering. However, I've got quite a few random disconnects, far more often that I'd have in past patches.
01/25/2019 04:33 PMPosted by Gimpzor
I wonder if the information that you can't disclose is the difference between to 10+ year old servers and the other new(er) servers they have.


It is really complicated. I don't honestly know all the details. They don't let me go in those areas and don't give me a run down on what they do. I get crumbs from the Tech Support Forum Agents, but that is about it. Most of that I find out from what seem like offhand comments. I end going "wait since when did it work that way?!".

Without all the details though I feel it is irresponsible to try to assume and fill in the gaps myself and share. I don't want to provide incorrect information or mislead anyone.

My guess though...either routing OR...a new data center. *cough* It is not east coast. I have NO idea if any D3 services run from it though. I don't think so, but without details I could be totally wrong. They are not going to give me a network diagram.
01/25/2019 01:30 PMPosted by Gimpzor
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.


D3 has become so popular the servers cannot handle the load. The excitement about Diablo Immortal has created so much hype everybody is playing the game!! *evil smile*
Pain Enhancer gem may be causing interrelations. Try with and without it.


It wasn't PE on my end. I play without that gem and the servers have been wholly lagtastic even in a solo 70 GR. I've had more rubberbanding this week than I've had in the last year. And this despite my MTR showing a clean route.

Since it could be any number of things causing it, I'll just have to live with it until Blizzard narrows down what's going on on their end. I know it isn't their peering routes because other than the sync-stutter (the rubberbanding), everything feels more rock solid than last season where I experienced wild latency swings. Here it's solid latency, but with something wigging on the server side of the equation.
01/25/2019 01:30 PMPosted by Gimpzor
The servers for the past few days have been very unstable. Does anyone know what's going on, or if Blizzard is aware of this?

Games completely freezing or stuttering down to 1fps. All servers jumping to high latency etc. At first I thought maybe it was my isp, but everything has checked out fine from that standpoint, and a lot of the people on my friends list are complaining of the same issues.


looks like someone is using crappy internet service
I spy auto server blame. who knows whats up, the 'it could never be something on my end' talk is not ruled out guaranteed.

Join the Conversation

Return to Forum