No movement impairing mobs but cant move

Technical Support
Hello,
My boyfriend and I have recently been having an issues. While fighting mobs without any movement impairing effects, we cant move. We both play Barbarians and use whirlwind as our main attack.

We have tried everything that could be wrong on our end, including re-installing the game and replacing our mouse. Has anyone else had this issue or is there something wrong with our computer? The issue has been going on for about 3 months and is making it very difficult to play a game we both love. Thanks for any help anyone can offer
I assume you both are playing on two PCs on the same local network (home).
If both of you can't move at the same time, it sounds like a network latency or disconnection problem.

Try the steps in the troubleshooting article:
https://us.battle.net/support/en/article/112206
Click BLUE texts for detailed procedures.

If problem continues, please get a WinMTR report and paste it on your reply.
How to run WinMTR: https://us.battle.net/support/en/article/27780
I don't have the issue on my laptop (running wireless internet and windows 7. Its completely up to date). His computer is all up to date and we have tried what the support suggests and are still having issues. Ran the test thing and no issues was found
We also dont experience it at the same time

Join the Conversation

Return to Forum