Cannot pick up or drop items in party.

Bug Report
Players in party cannot see anything I drop and I am unable to pick up anything people drop even if I am in the same rift as them. I have had this account for years so it is not the new account restriction. Please fix ASAP, really hurting our climbing.
I have the same problem
Same problem.
Same here
a friend of mine have same issue!
I have the same problem, tryed to run a repair on the game.. Did not work..
I have the same issue
Same, Blizzard can you provide a solution please?`Thats annoying as hell....
I have reached out to the Blizzard Support since i had the same issue + items being faded color all the time. It seems to be a bug and i got told that it has high priority to be fixed since its affecting a larger group of players. So i just hope as all of you that it will be fixed soon.
Well I'm actually glad to see that cause I have the same problem for a week ; can no longer drop items or pickup ones from friends in the same party and have faded color items as well. I've tried to uninstall and set all settings by default, and I've also tried to play on another computer, nothing works. Waiting for upcomming news... Goodluck to everyone with that.
Same problem but closing and restarting game fixed it.
Unfortunately it doesn't work for me... I just tweeted to diablo's official account, not sure it will change anything but worth to try :)
How is this not fixed yet...
Same problem. Logged out and in. Played on 2 other computers that both play other accounts without the issue. Performed Scan and Repair. Verified all option settings are identical to other accounts. Veteran player, so no new account reasons.
Same problem here both yesterday and today. Faded item labels and unable to trade with anyone :( Also tried restarting and even reinstalling the game, but no change.
Up. still bugged
Still bugged... nice blizzard keep going
same
same
Same problem

Join the Conversation

Return to Forum