PS4 Kill Belial/Skeleton King Crypt

Console Bug Report
When player 2 activated zone change from City of Caldeum to Imperial Palace for the Kill Belial bounty. The zone shift sent us to The Skeleton Kings Crypt (had previously killed Skeleton King for a different bounty).

We went back to City of Caldeum, and tried entering Imperial Palace again, where Player 1’s character was sent to the Skeleton Kings Crypt, and player 2’s character disappeared, with audio from the Campaign instance playing as background audio. Upon Player 1 creating a Town Portal, it lead to the ACT 2 Hidden Camp and Player 2’s character appeared on screen again.

We are in Torment 14, local shared screen multiplayer, had completed the Act 1 Bounties (which included the Skeleton King), did *not* open the Large Horadric Chest (stashing them for the Seasonal gold Challenge), and completed 4/5 of the Act 2 Bounties, with Belial being the last.

All attempts to get to Belial failed, until quitting and starting a new game, at which point it worked.

Videos of glitch attached below.

https://www.youtube.com/playlist?list=PLAkuFwocfzITej6g7gpEIpsWKg1YuCFtA

Join the Conversation

Return to Forum