Items Frozen In Invatory

Bug Report
Items become frozen in my invatory. I so far have 3 items which I cannot click or do anything with. Iv tried relogging and restarting. Anybody have the same problem?
Windows 10 ? try switching to a different video mode.... Fullscreen, Windowed(Fullscreen), Windowed.
Yes, I am having the same issue myself. and yes, I'm running Win10 as well.

Instead of the game arrow, it switches to my system arrow in my inventory and I can't do anything with the items I hover it over.

It also does this whenever my characters reach higher paragon levels. Doesn't matter what type of attribute I get whenever my characters level, it's always on the 3rd choice and I can't click on it.

After reading your above post -before posting this- I have tried those things and
they didn't work either.

Any other suggestions I could try.
07/04/2019 11:50 AMPosted by RutoFlame
Any other suggestions I could try.
Looks like some other programme is grabbing the focus.

This is the wrong forum to address that... Blizzard provides no support here.

I'd make sure your video drivers are up-to-date.

Are you running programmes in the background that have overlays such as Discord? I'd try to shut them down and see if the issue goes away. Blizzard has a short list of overlay programmes that can create issues here : https://us.battle.net/support/en/article/31366

If you need more help... post to the Technical Support forum or contact Blizzard Support directly -- today is a holiday in the US... not sure what level of service Blizzard has today. Also, there was an magnitude 6.4 earthquake some 200 miles north of the Blizzard HQ in California earlier today.

You can contact Blizzard Support here:
https://us.battle.net/support/en/help/product/diablo3/303/1397/channels

Join the Conversation

Return to Forum