Updating System Files.

Technical Support
Prev 1 18 19 20 21 Next
uhm...i don't have an agent.913...i only have 534 and 954....
I'm stuck at Updating setup files

and can't install this game on my desktop

I get error BLZPTS00007

I have deleted the Program Data Blizzard file, Blizzard entertainment file, Battle Net file
I have changed Internet Explorer settings (Google Chrome is my default browser, I don't understand what role Internet Explorer plays in this) as directed
I have used End Process on Agent.exe
I have done everything everyone has suggested

I really hope Blizzard fixes this so that I don't have to change 12 settings on my computer just to install their game. I've played every Blizzard game since Warcraft I: Orcs vs. Humans and never have I seen a launch be this frustrating!!!
I'm also having the same problems. I was having the problem with the beta and the installer continues to give me problems. No solutions blizzard is giving has worked. Some help would be nice
Bump for issue still not resolved
I did this and I got to the install screen, but after I agree to the license terms, it says an decryption error occurred....

I've uploaded my working Battle.net files to see if it may help anyone. Feel free to test and let me know.

http://www.gamefront.com/files/21699449/D3+-+Battle.net+Files.zip

Place them inside: C:\ProgramData\Battle.net

Agent
Client
Setup


OMG!! Thankyou!!!!!! After having no success with any suggestions, this worked for me!

Thanks for thinking to do that and thanks for the files upload....your a champ.


I got further on this, but once i got to the installer screen, and hit "Agree" i get a message that says an unexpected decryption error has occurred please contact customer support. then it crashes...
I did this and I got to the install screen, but after I agree to the license terms, it says an decryption error occurred....



OMG!! Thankyou!!!!!! After having no success with any suggestions, this worked for me!

Thanks for thinking to do that and thanks for the files upload....your a champ.


I got further on this, but once i got to the installer screen, and hit "Agree" i get a message that says an unexpected decryption error has occurred please contact customer support. then it crashes...


HOLY CRAP! I actually retried this, but only did the Agent and Client portion, and it started to work....
See if you have the Windows Secondary Logon service enabled. The game requires it and I know a lot of people disable it in hopes of making their computer more secure. It's enabled by default by Microsoft.

To check, go to Control Panel > Administrative Tools > Services and scroll down to Secondary Logon. right click it and select properties. Check it's startup status and change it to automatic or manual if it's currently set to disabled.

If it's disabled, the D3 Setup.exe will appear to do nothing when ran and the MOP installation will appear to hang on Updating Setup Files. There may be other symptoms but these are two I'm seeing the most right now.

Thank you.
I was experiencing the same issue for 3 days and after every possible solution still couldnt fix. Tired of waiting on blizzard i just re-installed my os. I dont consider this to be a solution, but if ur as frustrated as i was it'll work. Just make sure ur graphics card and network card are updated and make d3 the first program u install. :( but i can play now after sacrificing everything else that was saved on my comp, lol.

Also note: it's good to ensure that it's not ur network blocking install progress by trying to install on another computer on your network first. If you have another.
i have tried it all same problem i delted my the profram data only for it to do the same thing checking for update files...SOME ONE HEP ME!!!!!!!
Thanks worked perfectly :)
THANK YOU SO MUCH BRO
To Abe and the rest. I stopped reading at page eight so I apologize if this was already mentioned. I was having the same problem as you all and had tried every fix mentioned up to page eight - so those solutions were active. On a whim I went into the agent.exe file properties and selected run in compatibility mode for Windows XP SP 3 and relaunched the download (after having force quit agent) and it took me immediately to the launch screen.
Not sure this helps but given the wasted days of trying to fix this I wanted to make sure to share my solution (though it looks different for everyone).
Hope to see everyone on this thread in game. Take care.
In my case i set up appropriate port forwarding from my firewall and re-ran the setup installing over the already existing folder and the whole thing was working again in < 1 minute.

As a mention about the secondary logon it's actually often not enabled by default i even checked on my freshly installed laptop running win 7 64-bit pro en and it came disabled by default.
still same problem...:(
So i finished the download and when i press play nothing ever loads up what do i do?
SO my problems are either invalid installation options or initialize streaming....been trying everything on everyones posts and still nothing...any more suggestions?? been trying since tuesday morning
Worked for me too

thx m8
You, Sir are a saint and a scholar.....and....i think i love you....thanks.
I have a real cool problem.

Go to install the game on Vista, gets through the set up file junk, i click install - click agree to the ToS/ToU & it says "Diablo III requires a newer operating system to run" (which is weird because the outside of the box says it works with vista?)

So, as I wait 80 minutes for a representative to talk to, I decide to run in 'safe mode with networking'. I open the file there and run as administrator. Now I get to the part where I'm stuck on updating system files.

So the rep tells me to delete my avg, so here I am, having the same problem with absolutely NO virus protection.

Heres the conundrum:

Run windows in regular mode & have it tell me I require a newer operating system (than vista)

or

Run windows in Safe Mode with Networking and have it get stuck @ updating system files.

....happy birthday to me. it's been a joyous past 3 hours.

Join the Conversation

Return to Forum