.part files remain, downloader exit after chk

Technical Support
So, I have 7.60GB worth of downloads completed for a while. But it bothers me that I have a file with a .part extension remaining (Tome 2).

I've tried restarting the downloader and pointing it to the same directory a lot of times (with admin, compatibility setting, firewall off, antivirus off, secondary logon service enabled, p2p mode off). And it will check until it gets to "7.60GB of 7.60GB" with "2 minutes remaining". But then the downloader will just exit; no prompt, no error, with the .part file unchanged (@ 4,115,295 KB).

If I open Diablo III Setup.exe manually, I eventually get to the "fire in the sky" thing. But reading through the tech support forums, people say I should not have a .part file remaining; and I don't want this to become a problem biting my !@# on launch day.

Anyone can help? I have Win7 64 bit SP1.
Try this,

Delete the Tomb2.part file and re-run the Downloader it should see that no tomb2.mpe file exists and redownload the whole file.

Let me know how it goes.
You could probably rename the file, remove the .part ending and run the downloader again for verification.
ok, I renamed Tomb2.part and removed the .part extension. And now the downloader wants to re-download the whole 2nd tome (connection info shows a more than half chunk that is not red). I guess I'll find out if this works after ~10 hours.
I have a similar problem but with tome 3. Also the downloader is still open and says it has "finished downloading" yet tome3.part remains.
Ok, it worked now after re-downloading the whole 2nd tome.
So would you recommend this if all your files have .part?

meaning after the downloader was supposedly finished, after leaving it on over night, all the files were .part. I am in the process of re-downloading everything and it seems to be working the setup at least is no longer .part.
if the DL is still open most likely the files are still being compiled and not ready.

kids please let us know how long everything is frozen or still open. every bit of detail helps since we are not there with you.
Kids is probably not the word to describe people my friend just saying.
I'm getting this error still too, a blue post/someone who knows how to fix this would be awesome. For the record, it checks the files hits 7.6gb and instantly closes, no freezing or waiting or anything, leaves me with the tome3.part still.
Great stuff.
Such quality software, NOT detecting flaws and NOT automatically merging .part files.
The Problem is, i closed the downloader when it said download finished. THEN i saw the part file and realized i should have left it open. Now, once it was closed, the damn bad installed Downloader wont merge the existing file but needs to redownload ... wtf is that, even i can program that better!!! Or at least write a proper status window so we know not to close the downloader!!!!!!!!1

Join the Conversation

Return to Forum