Stuck at Updating Setup files.

Technical Support
Prev 1 5 6 7 26 Next


Maybe my pathway is wrong. I'll fool around with all the advanced settings and tabs till i find it. I am the admin and I even made every account on this computer admin with all rights just incase that was the error. I'm looking further into this....


This is a shot in the dark for you but it might have merit.
Check the ownership of the Battle.net folder. If the user you are not logged in as is not the owner of the folder, try taking ownership of the folder with the user you are logged in as. This could possibly fix the greyed out box to run as administrator. I cant be 100% sure but I don't think it has a chance of working until the box is no longer greyed out.


I am the owner... I don't know why it's greyed out like that. But I can make a shortcut run as admin. But if i Go to the source and the only run as admin i see is in the compatability tab. And there I can choose to run as Service pack 1, 2, 5, 95, 98, 2000. In my Compatability tab there is a box called "provilege Level" Where there is a greyed out Run this program as an administrator... Dunno?!
I have Win 7 and so far from what I experienced, as long as you can set that effing Agent.exe *32 to administrator and Win XP service pack 3 compatibility(<-that 2nd part might not be necessary) then end the Agent process you should be in the clear. Right now I'm at the login screen awaiting midnight watching some crow peck at a rock next to a dead looking tree in the moonlight behind the Diablo 3 logo. This method worked. Or atleast for me anyway dangit.
Anyone know the solution for windows 7?
Control Panel -> Network and Internet -> Internet Options -> Connections -> LAN Settings button at the bottom -> uncheck "Automatically detect settings"

Thought I would toss this in the thread, sorry if it has been mentioned before. Been trying to help a buddy DL for 3 hours now. I realize this was just for slow download speeds but it seemed to fix his stuck at updating as well. Found in this thread http://us.battle.net/d3/en/forum/topic/4926592965 within 3 mins he was good to go.

If it helps anyone Im glad to hear it.
Control Panel -> Network and Internet -> Internet Options -> Connections -> LAN Settings button at the bottom -> uncheck "Automatically detect settings"

Thought I would toss this in the thread, sorry if it has been mentioned before. Been trying to help a buddy DL for 3 hours now. I realize this was just for slow download speeds but it seemed to fix his stuck at updating as well. Found in this thread http://us.battle.net/d3/en/forum/topic/4926592965 within 3 mins he was good to go.

If it helps anyone Im glad to hear it.


Yea ive seen this work for someone on this forums, it does nothing for me tho

and yes iam no W7 x64
Nice fix thanks. I had to look up how to view the stupid hidden files so this should help people with the rest http://windows.microsoft.com/en-us/windows7/Show-hidden-files
It Worked for me!

Go to Control Panel > Administrative Tools > Services

Scroll down and find “Secondary Logon”

Right Click > Properties

Change it from ‘Disabled’ to ‘Automatic’
i had this problem. had to turn off my firewall (spyware doctor) and it instantly worked. Running as administrator did not work but turning off antivirus ect did.
Things to try:
Go to your program files folder and delete anything that has been installed the folder will be called diablo 3, right click on the set up and go to its properties and run it as administrator.

Worked For Me!
HI,

SORRY FOR CAPS.

I BEEN TRYING FOR 7 HOURS NOW, WITH NO LUCK, UNTIL I SAW THIS POST ABOVE ^^

'"I had the same problem and tried the suggestions on the forums to no avail. Like Maeloria, I attempted to run the setup in Windows XP (Service Pack 2) compatibility mode, and it brought up the launcher but would not let me install either.

So, I went ahead and tried Windows XP Service Pack 3 compatibility, and it's installing now. :)

So, right-click on your setup .exe file and select Properties. Then go under the Compatibility tab and use the Compatibility Mode drop menu to select Windows XP Service Pack 3; Apply and try to run your setup again. :)"


PLEASE COULD EVERONE TRY THIS, iIT BLOODY WORKS, GOOD LUCK
I have Win 7 and so far from what I experienced, as long as you can set that effing Agent.exe *32 to administrator and Win XP service pack 3 compatibility(<-that 2nd part might not be necessary) then end the Agent process you should be in the clear. Right now I'm at the login screen awaiting midnight watching some crow peck at a rock next to a dead looking tree in the moonlight behind the Diablo 3 logo. This method worked. Or atleast for me anyway dangit.


Can you tell me how you set Agent.exe to administrator plz... :/


This is a shot in the dark for you but it might have merit.
Check the ownership of the Battle.net folder. If the user you are not logged in as is not the owner of the folder, try taking ownership of the folder with the user you are logged in as. This could possibly fix the greyed out box to run as administrator. I cant be 100% sure but I don't think it has a chance of working until the box is no longer greyed out.


I am the owner... I don't know why it's greyed out like that. But I can make a shortcut run as admin. But if i Go to the source and the only run as admin i see is in the compatability tab. And there I can choose to run as Service pack 1, 2, 5, 95, 98, 2000. In my Compatability tab there is a box called "provilege Level" Where there is a greyed out Run this program as an administrator... Dunno?!


Ok...
I got another one for you...

Go to your "User Account Control Settings"
There should be a slider with 4 options. Go to the bottom option, which should be "Never Notify Me". This should allow ALL programs to run as administrator when they need to regardless of that check box or right clicking and running as administrator. I am not sure if you need to re-log on or not after you change that setting. But if you change it and it doesn't work, give it a good old restart and try again just to be sure.
I have Win 7 and so far from what I experienced, as long as you can set that effing Agent.exe *32 to administrator and Win XP service pack 3 compatibility(<-that 2nd part might not be necessary) then end the Agent process you should be in the clear. Right now I'm at the login screen awaiting midnight watching some crow peck at a rock next to a dead looking tree in the moonlight behind the Diablo 3 logo. This method worked. Or atleast for me anyway dangit.


Can you tell me how you set Agent.exe to administrator plz... :/


Read all pages of this post and its easily found...
I posted how on page 4(?) I think...
@ GUTS

Sure dude, I don't know why the option was greyed out for ya, but I literally did it from the task manager screen on Win 7. It might be a little different on Vista or not. You could try right clicking on Agent.exe*32 and go to properties to find where it is in your PC and go directly to it and trying to right click > properties > admin that way. By the way the Agent.exe I seem to have is .954 . I dunno if thats the same with everyone or not.
Now I have an error saying I cant install the game!
After a few frustrating hours, navigating to the battle.net folder and deleting it then rebooting and redownloading setup client worked. I noticed when I ctrl+alt+delete I had 3 agent.exe running. I ended them and that is why I rebooted...for good measure. I also ran ccleaner cleanup and the registry cleaner after booting back up, though it was probably not needed.


I am the owner... I don't know why it's greyed out like that. But I can make a shortcut run as admin. But if i Go to the source and the only run as admin i see is in the compatability tab. And there I can choose to run as Service pack 1, 2, 5, 95, 98, 2000. In my Compatability tab there is a box called "provilege Level" Where there is a greyed out Run this program as an administrator... Dunno?!


Ok...
I got another one for you...

Go to your "User Account Control Settings"
There should be a slider with 4 options. Go to the bottom option, which should be "Never Notify Me". This should allow ALL programs to run as administrator when they need to regardless of that check box or right clicking and running as administrator. I am not sure if you need to re-log on or not after you change that setting. But if you change it and it doesn't work, give it a good old restart and try again just to be sure.


This is a very interesting idea. I can't seem to find this "user account control settings" however. I'm still searching for a place that would let me clicke the never notify me option....
Uh actually it was page 3 by Moburt I believe. I tried deleting the battle net folder but that did nothing for me then I tried that person's method and boom shakalaka. It worked.
same....dunno how to fix it

Join the Conversation

Return to Forum