Install says I need to reinsert the disc

Mac Technical Support
Okay now I have something. I went to battle.net to download a new downloader. I put my birthday information in and I hit mac. What I downloaded was another Diablo 3 Setup and I used it. I am now on a launcher that looks more likes WoW and it is downloading another 8.1GB and I am at 11%. I also have a gray play button.

Am I atleast in the right direction now?
Yup, you are using the new installer. Let me know if this works out better.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...
Alright no luck with the deleting the .part files.

Will be re-downloading everything.

Goodluck everyone!
Try the new installer on Battle.net and see if it helps. It is no longer using the Blizzard Downloader.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...
Just wondering how big is the game file. Am i downloading the entire game* again? or is this more of what I already have.
Mine is 8.47 gigs at the moment.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...
Yea, I had the same problem as many people did at first as well. I was getting the "please insert disc," if problem persists, download the digital version. So, I just went back onto Battle.net and re-downloaded the digital version, and it worked beautiful. I now have the sweet log in screen.

I can't wait to play tonight!!!!
I solved the problem without redownloading everything.

Just go to the folder where you downloaded the installation files and delete everything but the 2 big MPQ files.

Use the same downloader you used to download the client (Diablo-III-8370-enUS-Installer-downloader.app) and wait for the other files to complete. After that, the installation will open automattically and everything should go smoothly.

Oh, and I did that behind a proxy/cache server.
new download almost done but, which 2 folders exactly?
Okay! Finally got to the log in screen! I Basically had the problems noted above, did a completely new download and after the download it was ready. Thats all I had to do. Was easy but time consuming.

Thank you Machkhan for the help
Blue post on this at :

http://us.battle.net/d3/en/forum/topic/4926863805#13

If it's asking for a disk then it means an entire data tome is missing from the download. I'd recommend restarting the downloader to see if you can pick that up.

When restarting the downloader, make sure to select the same download folder that you did before. It should have the Diablo 3 installer file inside it. Allow the downloader to completely finish. It will launch the installer on its own when it is done.


So basically go into your battle.net account management.

Click on your D3 game.

Redownload the download.

Open and point to where you started the download for the D3 setup.
I had the problem that it stops at 11% and says I need the disc. Now Im gonna install the client from Battle.net, but my question is: Do I have to remove the files I downloaded from the other download or can I keep them without making this new clientdownload fail?
I had to delete the original download and redownload/install everything. It was not 7.60GB as originally downloaded it was just over 8GB. Works like a champ now.
05/15/2012 11:19 AMPosted by Viktor
I had the problem that it stops at 11% and says I need the disc. Now Im gonna install the client from Battle.net, but my question is: Do I have to remove the files I downloaded from the other download or can I keep them without making this new clientdownload fail?


No just redownload the client from battle.net and point it at the folder your downloaded the D3 setup into.

It should check the files you already downloaded.

Join the Conversation

Return to Forum