stuck on updating blizzard launcher

Technical Support
I fully downloaded the game and then it gets stuck at launching. i closed it and reopened and now its stuck at updating blizzard launcher.
same
same.
As are many. Probably best to stick with one of the existing, larger threads discussing it - it'll be easier for Blizzard to track and respond, than for everybody to post their own. This isn't a new problem, it happened to me (and lots of others) during the beta as well, it affects some percentage.
Try deleteing the battle.net folder and try again.
05/14/2012 11:24 AMPosted by Lèroy
Try deleteing the battle.net folder and try again.


i know you are tryng to be helpfull, but iam starting to get pissed everytime i read that sugestion.

it dosent work><
Go to processes in task manager and shut down Agent.exe and retry. This worked for me
They knew about this bug in beta. "They'll respond to it" LOL.

The only work around I found then is to disable ALL non-microsoft services and all startup entries (with msconfig).

But apparently that doesn't even work tonight.
I shut down my agent.exe and it worked for me. Thanks CptWinky!
AH!!!! Man this is killing me i want to help everyone with the help i got and i write this in hopes some one knows what im talking about and help make it more clear. I was stuck at the Battle.net Update Agent not working/ Launching Blizzard something so i had done every trick in the book to get it to get past it to no avail. I read an article on 'This helped me it may help you' and basically i went to the start button typed in Command Prompt and Typed in 'Netsh something Reset' and i can not remember exactly what i typed but it WORKED!! someone has to know what im talking about! So we can help others!
@DyingBreed

BRILLIANT!!!
I googled that, and found this
http://blue-en.mmozone.de/customer-support/t2350975464-here-fix-launcher-not-start.html
Worked perfectly for me...
i was having this problem but as soon as i ended agent.exe it went straight to the play button thanks so much man i appreciate it.
You need to close the launcher client and open the task manager, go to Processes and 'End Process' called 'Agent.exe'
Than restart the launcher.
Worked for me =)
TASK MANAGER AND SHUT DOWN AGENT EXE.

IT WORKS
no it doesn't
No it doesn't. Shutting down Agent.exe made no difference for me at all.
thank for the tips.

http://blue-en.mmozone.de/customer-support/t2350975464-here-fix-launcher-not-start.html

As for the below if the above links not working.


here fix launcher not start

hello guys well i had problems that i cant start launcher wow when i did all these in CMD:

netsh winsock reset
netsh winsock reset catalog
netsh interface ip reset C:\DAF-interface-resetlog.txt
netsh interface reset all
netsh firewall reset

and it work perfectly hope it work for you and thxya

as above is base on Benafidz


Hmmm...... it seem unable to work... T_T
my battle net update agent crashes all the time when i try to start setup.exe.
Shutting down agent.exe with task manager doesn't help, because the launcher starts the update agent again, which in turn crushes.

tried the netsh ... commands. and doesnt work
Any help much appreciated
same here...not working, stuck at 1/2 way updating...

Join the Conversation

Return to Forum