Downloader does not save progress?

Technical Support
I might be missing something fundamental, but I run the Diablo III installer download and it starts to run what appears to be the blizzard background downloader. However, any attempts to restart the download just starts everything over again.

I have checked in the Diablo III folder for a downloader exe file, but there is none.

I'm very confused.
When you restart it, you must select the same parent folder holding the "Diablo-III-8370-enUS-Installer" folder. If you select the installation folder, it's going to make another folder inside and start over.
Okay, so the folder selection process each time is normal?
Yes, but the downloader will create the folder "Diablo-III-8370-enUS-Installer" unless it already exists where you tell it to go in which case it uses what's already there and continues where it left off.
It started again for me too. I had downloaded 5GB, closed the downloader and the next day chose the same folder I did the day before, it said checking, then it started from the start.
keeps starting over every time it goes away for me. Never going to be able to dl it at this rate. pretty disappointing blizz cant even make a reliable dler.
This issue is being caused by the game files that you download not being saved correctly onto the computer. This issue can be caused by administrative rights on the computer. One thing you will want to try is running the pre-download as an admin by right-clicking on the download and selecting run as administrator. The second cause of this issue is computer security software not allowing the files to save as well. For that issue you will want to disable those software's.
its normal to ask you to select where to DL it to because you never finished the process. when you select where it verifies that you ahve the proper folder then verifies what you have dl already then it starts off where it needs to. if it is not saviing anything maybe its your firewall or virus protection programs. and run as administrator.

update us what happens
I run it under admin and I have had my firewall disabled for years and dont even have virus protection installed
05/13/2012 11:05 AMPosted by Gluscus
I run it under admin and I have had my firewall disabled for years and dont even have virus protection installed
I have this same problem and it tells me I have a firewall.
I even copied my folder.. which has 1.5 gb dl.. try to paste it into the folder i dl to, open the downloader and it says I have ~300 mb dl only.
Dear God this has happened to me several times now. I makes me so angry. I have a crappy connection too, and now will not make it to the launch. I wonder where it is stashing the data... It is so frustrating that I am eating out at a place with a much better connection just trying to get back where I was before I had to restart my computer. Seriously Blizzard, this is mindbogglingly stupid.
Can we get a blue answer to this? It appears that even Admin access doesn't stop this, at least according to Gluscus. Is it possible that the installer can be down loaded some other way? Please, Blizzard, don't leave us hanging.
I keep having the same problem too :/ with a crappy unstable connection
This has happened a third !@#$ing time. I even made copies the files and they too got over ridden. I am done. Screw you and your lack of help, Blizzard.
I'm having the same problem. 6.69gigs downloaded and now the tracker isn't responding. Everytime I've closed out the downloader and started again, it makes me restart.....
you dont even mention where you are in the dl process taht you just keep restarting the DL. are you stuck and i mean has i been like 3hrs at 30% or does every hour make it a new percent etc etc
details people.. how can we help you if you just give us a short summary
I made it all the way to 7.60g done, but it stalled and said still DLing for about half hour. I canceled the downloader and started it back up after I restarted my internet connection as well. It started to check, but said I had less than 1g and now it's doing it all over.
Me too.
Bump. We would like an answer to this problem.

Join the Conversation

Return to Forum