Diablo III won't work for pre 2007+ iMac

Mac Technical Support
Hello I was having a problem getting the beta work with my iMac which system specs. are a 2 GHz Intel Core Dou, 2 GB 667 Mhz DDR2 SDRAM Memory, a ATI Radeon X1600 chipset model, and resolution of 1680 x 1050. I wanted to buy the Diablo III game but with my iMac that will be impossible. Is there a work around this issue because I am a college student and its very hard to buy a new Mace with my finances going to my schooling and living arrangements.
Which issue ?

Saying something isn't working isn't very helpful when you aren't specific as to what you mean by not working.

What are you doing ?

What are you seeing ?

What error messages are you getting ?
The ATI X1600 iMac doesn't meet system requirements for Mac.

If you already have boot camp, you might be able to install it there, but it is listed under poor performance for Win.
________________________________________________
Mac Tech Support for Baaaaahlizzard Entertainment | Sun-Thur

This is small step for me, but big step for humanity. Or something like that...
I'm in the same situation. Very sad news for me. I understand my system is outdated but it plays WoW fine, I wish it was able to do so with Diablo 3 as well. I shouldn't have made that assumption, I know. No point in being an Annual Pass holder now though as this was the only reason I signed up.

I just went from extremely excited for tonight's release to extremely bummed. /sigh
Comment deleted. The info wasn't applicable.

Join the Conversation

Return to Forum