Really slow Diablo III download speed

Technical Support
Prev 1 6 7 8 Next
I followed the first step and I instantly tab to see my download speed and it jumped from 200kb/s to 1.5mb/s thank you so much!
Someone care to explain why this worked? I thought there was no way this would fix anything but then bam up to 3 mbps
FIX (Thanks to Xinthar):

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"


OR

[quote]Start > Run inetcpl.cpl > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"


This worked 100% for me. Went from 20bytes/sec to 2.16MB/sec. Thanks!
I did this, and the port forwarding, but my download speed still hasn't budged. It's currently 0kbps.

When I restarted the installer, it starts out at 800kbps, then slowly decreases to 0. Anybody know why?
Update
Ok I have tried almost every fix for every problem on these boards and still cannot get this to update right. Run the installer and it gets to about 23% then slows down to under 1kb a sec most of the time under 100bytes, and often stops and down loads nothing for minutes at a time. There is no way this game is ever going to finish the last 6 gigs of the first update at 24bytes a sec!!!! please can we get a blue to respond? I'm not the only one this is happening to and would like to play the game at some point this month.
WHY on earth did this work?! Is blizzard autodetecting some dodgy settings? Thanks a bunch tho!
Why does this work for some people but others it drops us to 0....
It was DEFINITELY the port-forwarding that was getting me. Look to the blue comment and forward ports 1119 and 6881-6999.

When I did it I got an error message from the downloader saying it couldn't find some files. I restarted my PC and boom, downloading at 2 MB/s.

DO THIS. DEFINITELY IMPORTANT.

Even if you can torrent other stuff these ports are for Diablo 3 P2P specifically.
Downloading at 1MB/S, not sure if p2p is working, but doesnt matter. Will be done by morning. Sad it didnt use the beta files to quicken the download a bit.
I am having thsi same problem. i have 2 computers in my house and I have tried installing the game on both for trouble shooting. computer 1 stalls at updating setup files (wait around 30 minutes to an hour) when it finally passes, it downloads at 8kbs

computer 2, flies through updating setup files, under 10 seconds, and downloads the game in about 3 to four hours.

main problem is computer 2 sucks.

both computers are on the same wireless network and i have tried every fix i can find online for computer 1. adjusted all firewalls.

the only program that could block it is super anti spyware, but i dont think that blocks programs out
Why this LAN setting doesnt affect any other p2p software? After unchecking it, dlownload speed went from 300kb/s to 10MB/s.
Fixed my problem too! went from 50k to 10mbs!
The first fix did it for me, thanks:)
In order to resolve this issue, I had to do the following:

Go to Control Panel > Network Connections > Internet Options > Connections Tab > Lan Settings > Uncheck the "Automatically Detect Settings"

This changed my download speed from 56kbps to over 3mbps.


Good catch. Immediately fixed the problem. Thank you
It's work. Thanks a lot. ( Speed up 30 kb/s to 820 kb/s)
Dinks the fix you said at the beginning fixed it for me, THANKS!
I'm also interested in learning what it is about this setting that affects the Diablo downloader specifically. I've been using the WoW Downloader for years with the default "Auto-detect settings" setting in Windows and never had a problem. But for some reason the Diablo downloader, which supposedly uses the same general code, hits an issue with that setting? Bizarre.

I had the same problem as most everyone else here (17 k/sec in my case), and unchecking the setting immediately fixed it for me.

Also, it's worth pointing out that it's not physically possible to forward or trigger on port 6881 on my router (NETGEAR WNDR3800) because that port is being used by uPnP. (At least, that's what the router reports when I try to set it up.)
where is this setting on windows 7?
Unchecking the Automatically detect settings took my download from 9Kb to 4Mb

Join the Conversation

Return to Forum