Failed to run required program (Agent)

Technical Support
Prev 1 10 11 12 15 Next
well... What i'd like to know is why there are mulitple Agent Builds in use? I have seen 524, 868, and 954.. when I run the installer it gives me 524.. but I have seen a guy with 868 who is using the same OS as me.. win7 64 bit
Mine is working with 954. Have no idea what is going on. I'm trying to read the log from Agent.exe now...

I am missing the time i use to be a lazy student!!!

Right now, I have 2 times went thought the updating part, but followed with a wonderful new issue: communication error. It making me feel endless dark in the front...The Agent.exe is just a beginning of it...
This sort of trouble is just incredible. My game was brand new and it completely and utterly has failed to even download on the computer I want it on. I have tried almost every single fix, besides replacing my Agent with Im assuming would be the correct working version for Vista.
come on!!!!!
I had gpttp a point where I actually had a "initializing" screen and diablo III on my programs list.. then it was connection issues.. right now Im going to start from scratch.. go to the accounts page dlete eveyrthing in remotelu diablo III and try again... bs people.. B... S.
OKay... here we maybe go.. I am currently at the Diablo III splash screen.. it says installing.. I am at 14% and counting.. what I did..

1) deleted all my diablo stuff.. programdata battle.net foder.. installer all that stuff
2) Downloaded and ran diablo III client from my battle.net account.. ya know where yo utell them your birthday b4 you can download it.
3) Ran the client till it pooped
4) Now here is where I went tricky.... earlier in this epic I found this site
http://www.gamefront.com/files/21699449
and downloaded the zip file he puts up there.
5) Unzip the files and replace the C:\programdata\battle.net folder with the zipped files
6) Run the client you downloaded from battle.net
7)I am now at 30% installed as I finsih this posting.

p.s. I am running WIndows 7 64bit
4 days and still no agent still does not respond , the installation does not work, I spent money I ran down there ? All practices are on the forum what I tried and nothing works.Win 7, the DVD version.Thanks Blizz:((
Let us know how it goes. If it works for you, I will do a little more research into what works for Vista Ultimate. I expect some serious serious work to be done by Blizzard very soon or else its going to get ugly.
Oh. My.Gawd. So this installer is telling me my disc has been ejected... disc? WHat disc! this was at 43%.. so I hit "Ok" and it went to 44%.. again the error.. ok... 45%.. etc.. til now I am at 47%.. stuck at 47%.. so I hit cancel.. and it starts at one percent...

Really, Blizzard? REALLY???!!
Hi everyone!
Im from Poland and i had the same problem with the agent. Seemed that nothing could help. But then i found that i dont have newest version of Service Pack for my win xp. i downloaded it installed restarted computer and i was shocked... game installed properly.
So chekout yours SP version and drivers. Hope it will help.

Greetings.

P.S
On my second computer with Win7 i didn't have any problems with installing the game.
guys it seems like i can't open my taskmanager, i wanna try and close the agent.exe's in there or just see if they are there, but its quite hard when i cant open my taskmanager, can anybody help? i get the same error btw "BLZPTS00007"
i had problem....the error is ERROR: The fail "D:\Diablo III\Updates\d3-0-9558-Win-Final.MPQ" appears to be corrupt. You may need to dowload this file again. i dowload many times already but still same the error. please teach me. thans a lot
GUYS! I FOUND A FIX!!!!!

1) Right-click on the Diablo 3 the shortcut on your desktop.
2) Select properties from the drop down menu.
3) Navigate to the "Compatibility" tab.
4) Check the box for "run this program in compatibility mode for"
5) Click the drop down menu and select "Windows XP Service Pack 2"
6) Hit Apply and launch the game, it goes through some updating and BOOM, my launcher worked :D:D:D:D
For those who tried everything and still can't install the game. I think I have the solution folks. This is based on my personal experience.

I've tried everything that this forum suggested even tried installing the game in safe mode but still it doesn't work. So I made an experiment and tried it in my other computer (totally not for gaming). Then the game ran and I was able to install fine and pretty fast I must say with no issues on the agent. So this leaves me to one conclusion, something's wrong with my PC. It was mentioned in the tech support by blizzard that viruses can cause the game not to install and I believe (for those who experience the same thing as mine) are computers are infected by viruses. So I did the unthinkable and reformatted my computer. It is such a hassle to restore all my files and programs BUT the game finally worked. And yes, I can enjoy the game finally after 28 hours of hell!

I think there's a certain type of file/virus that's blocking the agent.exe to run. Maybe the guys in Blizzard can fix this problem because I think no matter how you try to protect your computer from viruses, you just can't (unless you own a mac).
Im having the same issue here i tryed to install the game from disc and it instally tryes to check updates and this error code incs..... got firewalls/norton offline and tryed to alt+f at IE and it doesnt work... cant figure this out
yep, same issue here. Blizzard needs to come through and figure this out and help. =/
I've tried every fix from every website with no luck. I know Blizzard has to be working on it but I would like to play once this weekend...
^^^my friend i respect you for having the optimistic point of view during these harsh times. I see pitchforks and torches with every person who clicks in this thread. lol
Im telling you guys, its Blizzards bull!@#$ launcher for the game not a virus, this solution has worked for a ton of other people:

1) Right-click on the Diablo 3 the shortcut on your desktop.
2) Select properties from the drop down menu.
3) Navigate to the "Compatibility" tab.
4) Check the box for "run this program in compatibility mode for"
5) Click the drop down menu and select "Windows XP Service Pack 2"
6) Hit Apply and launch the game, it goes through some updating and BOOM, my launcher worked :D:D:D:D
I was banging my head trying to get this to work. What finally helped was something mentioned earlier in this thread:

Turn off "Automatically detect setting" in my IE properties

IE -> Alt T -> Internet Options -> Connections -> LAN settings -> UNCHECK "Automatically Detect Settings"

I tried everything else mentioned above - turning off my firewall, antivirus, deleting the Battle.net folder, "run as administrator" - nothing helped.

Then I turned off this IE setting, and everything just started working.

Join the Conversation

Return to Forum