Failed to run required program (Agent)

Technical Support
Prev 1 6 7 8 15 Next
i let me download the eng EU version but i stopped it to see if i can get the US game client instead
Trying this now hope it works.
does anyone know if you can download and the eng EU game client even though lving in US it will be ok any differences at all. Because the US game client freezes half way and cant even start up the dam game.
im also getting this error. For me the agent.exe does not work when the setup tries to launch the agent it launches dllhost.exe instead. which then quits after a few seconds. the agent never actually launches. i have tried every thing listed in many forums to fix it. i am currently trying to install in on linux. but i dont have much hope for that. i really wish they would fix this. im sure they will as it seems to be happening to alot of people.
i guess will either try to install Win 7 or download the eng EU game client it did work but I stopped because im in cali so i was wondering if that has any effect on me. i know its not regoin locked but still wondering. I didnt know it was this hard to play a dam game. Its really dumb.
I tried running the program on unbuntu. It made it to the same place and stopped. Its makign me think this may be a hardware related problem since the unbuntu was a clean install and had no corrilation to my windows os except for that they use the same hardware. Which is crazy since my specs are above the recommended. but idk this is all speculation. for me the agent.exe never even runs. so i sure hope they come out with a fix
05/16/2012 12:34 PMPosted by CutthroatMob
i guess will either try to install Win 7 or download the eng EU game client it did work but I stopped because im in cali so i was wondering if that has any effect on me. i know its not regoin locked but still wondering. I didnt know it was this hard to play a dam game. Its really dumb.


I spent $120 last night on an upgrade to Windows 7 from Vista, it is still not working. Just a heads up.
http://patchup.info/d3/tfil/NA/

This patch site gave me an idea. Im in the US and I've tried to Download the digital version and have run into the same problems as most here with the Agent errors. I saw a post on this forum about this patch info site. Checked it out and found in the bottem there were options for different downloads for different countries. I clicked on the US version and had the same problem however when i chose the gbEN option the downloader is working. I dont know if the game will work or if they'll be serving fish and chips instead of hamburgers, however I'll let you know what happens!

Didn't help
So I downloaded all 7.60gb of the program through the euro GB version but i got the same error at the end of it. I'm giving up for the time being, being as ive spent the greater part of this day attempting to reach a solution. Good Luck all
I had "Failed to run a required program (agent)" appears with the error code "BLZPTS00007" I Had tryed all the methods that were give but i found one that helped. I fixed the Agent.exe problem and got the game to install by going into my registy HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Excution and deleting Agent.exe.
This is unacceptable.

have tried to:

0. Restart / Redownload / Run setup in a minute or two per error message (rolls eyes)
1. Run DIII Setup as Administrator and disabled firewalls and anti-virus.
2. Delete C:\ProgramData\Battle.net and rerun DIII Setup
3. Make sure Internet Explorer is not in WorkOffline mode
4. Create new Windows user with Admin privileges and run setup there (possible overlap)
5. Run services.msc and make sure the Secondary Logon service starts automatically
6. End Agent.exe in task manager while the update is running
7. Run the setup file in Windows XP SP3 compatibility mode (dont have it)
8. Run Regedit, go to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution" and delete Agent.exe (don't have it).
9. Move Installer into a clean C:\ProgramData\Battle.net folder and run as admin there.
10. Import someone else's battle.net folder and run agent.exe from that.
11. Made sure I got my area's and my correct OS version of the installer.
12. Ran agent.exe from the battle.net folder before running setup.
13. Disconnected ethernet from my wireless router and connected it directly to my pc. (to forgo a hardware firewall)
14. Downloaded a fresh IE 9 with default settings
15. Updated windows
...pretty much everything on this forum.

I have yet to download the game ffs.

Specific details about my BLZPTS00007 error:

-Win Vista 32 bit

-I see only 1 agent.exe running in taskmanager during updating.

-Updater stops @ 0% if I have the setup/agent files in battle.net folder.

-When building my battle.net folder, updater goes through two cycles...once very quickly (don't know if it finishes) and on the second cycle it stops 30-40% of the way.

- I got the .524 Agent version from the DIII client. If I manually import and run the .954 or the .868 Agent, updater just runs another agent.exe.

-If I run agent .524 manually, a command prompt appears and quickly disappears.

- I don't get a "Client" folder when setup builds my battle.net folder. Only "agent" and "setup."

Anyone else get this? Anything help?
I'm with Qwellious...tried everything
agree on Qwllious aswell i done the long list and my error is the same -When building my battle.net folder, updater goes through two cycles...once very quickly (don't know if it finishes) and on the second cycle it stops 30-40% of the way. im running on windows 7.. this is first time in my life i have experience this kind of bug when getting a game to work..
i have the same problem :S
but my friend that is running it on mac is playing it and didnt have any problems. XD feels like a sucker for the windows users
Take your IE out of Work offline mode:
  • Open Internet Explorer, Press Alt + F and uncheck Work offline.


-
While at it (Still on IE), click on Tools > Internet options > Connections tab > and select Never dial a connection.

After changing that option to never dial a connection, click on LAN Settings and uncheck every single check box there.


Thank you so much Barthas for this information wish i found it before i uninstalled the game :(
For a person like me that is taking NSA at ITT Tech i should of figured this one out but i was just getting so irritated that it happened today when i was able to play it yesterday. so thank you again.
just did it still im having the issue but when i try to select Never dial a connection i cant click anyway couse its all grey and im unable to select it as its set to default. should i be able to select one of the 3 options? before it will work?.
Thank you, Barthus. You are a scholar and a gentleman.
OK OK I GOT IT... I HAVE FIXED THIS EXACT PROBLEM AFTER DAYS OF WORK... IT IS A COMBINATION OF THINGS

DELETE THE GAME AND ALL BATTLE>NET FOLDERS...

GO TO INTERNET OPTIONS AND TURN OFF YOUR AUTODIALERS

THEN DO THE FOLLOWING AS KILLPRAY SAID

''I had "Failed to run a required program (agent)" appears with the error code "BLZPTS00007" I Had tryed all the methods that were give but i found one that helped. I fixed the Agent.exe problem and got the game to install by going into my registy HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Excution and deleting Agent.exe. ''

Join the Conversation

Return to Forum