could not install.invalid installation option

Technical Support
Prev 1 3 4 5 7 Next
I think its a matter of what programs are running in the background. It would not make sense that it not work one minute, then work the next, with the only change being a system restart. Like I said, I disabled my Antivirus and everything worked smoothly after that. Also, if you already have the Battle.net folder/program installed (like from World of Warcraft), it could be trying to overwrite that. Myself, I didn't have that installed. Most of the suggestions on this topic are generally steps that you should do when installing all (trusted) programs.
Thanks heaps for the help guys, but still no Diablo for me. Tried everything again and again, separately and together. I'll check back after work tomorrow.

Thanks again.
I'm running Windows7 and I had the same problem at the agreement page. But now the problem is solved! I just right clicked the installer (DVD version) and click Run as Administrator.

Hope this helps.
Turned off firewall and tried reinstalling it... Worked like a charm...
For the love of all that is holy and good, I have found an answer. Every other "answer" didn't work for me like the rest of you with this problem.

After waiting for a customer service rep on the phone for 2 hours I got a hold of one. I submitted all the info I had collected and she talked with a few people and they found, deep in those huge error messages, what was causing the issue.

If you have Content Watch you cannot install Diablo 3. I figured that might be the problem, so I had turned it off. But it needs to be uninstalled entirely.

I hope this helps. Many of you will need to ask your parents. I will let you know they can re-install Content Watch after Diablo 3 is isntalled and you can still play Diablo 3.

Even though there are not enough CSR's for Blizzard, the one I talked to, Kit, was awesome!
what about the people who don't have content watch???

I've have done everything you guys have tried and nothing. Restarts....delete folders....download digtial.....everything..and still getting that damn error message...
come on blizzard some answers :(
I got it working. Just make sure internet explorer is not in offline mode......agent needs that apparently
Same here. How rubbish.
got this problem on mac and wont work anyone any idea, i have tried everything..
i solved this problem with right click to setup file and clicking run as administrator ... its worked for me...
Bumb.

Some1?
Im trying to download the guest client and it wont work for me its giving me

COULD NOT INSTALL.INVALID INSTALLATION OPTION please try again...
I turned off firewall and antivirus software reinstalled the client XD PLEASE PRAY IT WORKS D:!
having the same problem. seriously needing help. working on it for 2 days now.. sooo frustrating!!
Okay so.... Yes running as admin/restart/file path change/comp mode/dig and disc ver/firewall and antiV off/cleared bnet hidden folder/online and reg at bnet etc.

I have the CE and I'm in US and have tried everything. After a few hours I randomly got to act II (the streaming error thing) and did those fixes and had to restart. I am now back to act I, invalid install option again.

I've been at this for hours and I feel like I got close but cannot get back to the next error in progression. If there is a different fix besides the ones listed on this and the eur/asia forums please let me know.

And again, yes I moved the exe and delete the bnet folder every time and all that. No i'm not running whatever thing that guy was talking about. Yes I tried everything in this thread and all others. Someone give me the next move before I start smashing kittens.
GOT IT~~!! You have to turn off firewall and AVG or what ever antivirus your running reinstall the client and it will work smoothly!
Those are all off and i've done the dig and off the disc. And beta is uninstalled. Anything else maybe?
I have everything shut off antivirus, windows defender everything and still only getting Updating setup files...... then Launching Blizzard Launcher for about 1 sec thant back to updating setup files... been doing that all day and nothing. This is crazy.
Randomly got in!!! Servers are full but I finally got past everything. I don't know just keep doing every fix from everyone and re-wait the 10 min setup thing everytime. Guess after a while if you're lucky it will randomly work.

Join the Conversation

Return to Forum