How to fix "unable to initialize streaming"

Technical Support
For Windows 7 Users
Go to Control Panel > Programs
Find the Turn windows features on or off
It should show up a check list
Find TELNEL
Tick on the boxes near them (should be Telnet client and Telnet server)
Hit OK

GO BACK TO INSTALLATION
GL HF

P/S: to other OS users, go to google and search for "unable to initialize streaming" and hit the first search in WoW forums, you shall see.
Disable firewall.

Or if you're using Comodo - use "Game Mode".
I only have KAV 2012 but I closed it 24 hours ago and I have turned off Windows firewall since the time I use Windows 7 Sir. It's not the problem.
Somebody call it the server issue cuz they hit the install continuously and it went well, I found this way better.
getting same error :(((

For me it goes till 1% n thats it...get the error msg :/ even if i take too long to click on activation it does that :(
uninstall the beta
i did this and it now works
It worked for me. Awesome and thanks !
I just ran the installer as an administrator and it worked
still error
bad luck for you :(
did you try the firewall thing and Run as admin?
Nope didnt work....tho i had just deleted the d3 beta folder b4 instead, tho I deleted the d3 beta registry folder from regedit n still no use :/
I don't know what else would cause that. But mine seems went well after that fix, no more error shows up.
Now I'm at the home screen of diablo, waiting for the release time.
I don't have TELNEL listed in my Windows features. I tried running as admin and turning off the firewall. The D3 beta and folders are long gone, but I still have the problem.

Join the Conversation

Return to Forum