Installer stuck at 77%

Technical Support
Prev 1 3 4 5 6 Next
Aymanesin

i love you .. and not in a gay way.

i just love you.

thanks man
Using Firefox, not IE, wat do?
I'm not sure if this 'really did' have any effect, but I'm inclined to believe this fixed my stuck at 77% issue.

Apparently a common thread with the downloader/installer is it draws its connection settings from your IE browser connection settings, so for me I went into Internet Explorer, Internet Options, connections, Lan Settings. Uncheck auto detect settings.

Close I.E. and in my experience it took a few seconds, I thought nothing was happening and then BAM! Zipped up from 77% in just a few short seconds.


I was installing from the DVD (collector's edition), and this worked for me! :)
The IE fix worked for me too! Even if you don't use IE the installer checks it for the download setting.
I'm not sure if this 'really did' have any effect, but I'm inclined to believe this fixed my stuck at 77% issue.

Apparently a common thread with the downloader/installer is it draws its connection settings from your IE browser connection settings, so for me I went into Internet Explorer, Internet Options, connections, Lan Settings. Uncheck auto detect settings.

Close I.E. and in my experience it took a few seconds, I thought nothing was happening and then BAM! Zipped up from 77% in just a few short seconds.


Thank you, this worked.
I've never opened IE before.
For people not using IE, keep in mind it is still probably installed to your computer. I use chrome, but i dug up IE opened it for the first time in forever, changed the setting suggested and the problem was fixed
yeah it has nothign to do with IE, you can just go to control panel, internet options, and follow the same steps. It brings you to the same place.
I tried to change the IE setting, still stuck at 77%, why?

nvm, waited for 1 hour, it start downloading now.
IE Settings worked for me. Many thanks.!!
This needs to be stickied not only because it actually is a legitimate fix, but I assume very little of the player base knew it drew connection settings from IE.

Well done, thank you!
i disable anti-virus.. it worked for me.. those still not working might want to give it a try? :)
The IE trick does work. Thanks guys!
The internet explorer trick worked, even though I don't use IE at all.

I can't understand why Microsoft continues to support it. It was always a freakin' virus and malware magnet, now it prevents games from installing properly? What a useless piece of crap.
been stuck at 93 percent for almost an hour, anyone else?

update: didnt fully read the IE trick. it does work, thanks :D
Aymanesin <3
Disabling the MSE (Microsoft Security Essentials) live protection fixed this for me.

Edit: The IE trick boosted my download rate even further.

Thanks Microsoft.
Had a slow download speed of about 800kb/s for the past 3hrs.
But the total downloaded was only showing 1.99gb.

Even though I use Firefox I loaded up IE and followed through.

My download speed instantly changed to 2.4mb/s and stayed.

Thanks <(^_^)>
For some reason i cannot use the ie trick because when i untick the box and click "ok" it ticks itself again.
This has been my third try and it's been at 77% for an hour now and it's starting to get really frustrating and i was wondering if there was another way to fix the installer.

Join the Conversation

Return to Forum