Cannot use this version of the application...

Mac Technical Support
Hello,

I am running into a problem installing the game on my Mac (OS X version 10.5.8). I am able to see the client finish, 7.6 gb/7.6 gb, however when it closes I am not able to click the setup button. Please use the attached picture for reference to the problem I am running into. I am not seeing a screen that gives me the option to install.

I can't seem to find a solution, any help would be appreciated.

Picture link: http://imageshack.us/photo/my-images/220/picture7vv.png/
Hi, check OS X system requirements sticky:
https://us.battle.net/d3/en/forum/topic/4903180328
Basically the issue you are running into is that your operating system is not supported.

You would need to upgrade to at least 10.6.8 (I'd recommend 10.7.4) to play the game.
I was running into this issue on Mac OS 10.6.8. I had run the downloader last week and the installer app was unrunnable. However today I fixed it by deleting the app "Diable III Setup" and rerunning the downloader.
Wow... just spent 4 hours downloading Diablo and I get this same stupid error. What the ****?

Join the Conversation

Return to Forum