Installer stops at 94% and loses "seeds"

Technical Support
Still not able to finish my download. I've gotten all the way up to 99% with 30mb left when I lose all my "seeds" in connection info. I've tried turning on and off the options in the downloader and that didn't help, both the p2p option and throttle option. It said something in the connection log about the "file being too short", whatever that means. When I restart it, it checks all the way back 94%, and starts downloading, ignoring the fact that I've gotten to 99%.

I was told it was by Blizzard tech support that "unfortunately all they could come up with is that it's my ISP". This is not true. I spoke to an ISP tech support and he agreed that it is not the case. I would really like to play the game I purchased, and to be honest I'm losing patience. Even if I download the direct files, there are still some tiny things I need to DL through the installer client, and that doesn't work.

Please tell me how to fix this.

Join the Conversation

Return to Forum