Press Play, Game does not launch

Technical Support
Prev 1 2 3 10 Next
its like the launcher does not look for missing files.... even after removing folders from the games folder it still says its up to date and ready to play lol.....where is the bliz repair program?!
I blame that stupid Agent.exe

I swear during the beta, anytime i wanted to launch the game I had to force quit Agent.exe in processes, because it never goes off on it's own and for some reason it would break the game trying to launch.

I made it work today by going into windows xp sp3 compatibility mode, but now that's not working anymore.

I also try force quitting Agent.exe and trying to launch again and that's not working anymore either.

IDK what they were thinking when they implemented this Agent.exe crap because it is a nightmare at BEST.


I AGREE over 9000%
so frustrated right now. i still don't understand how my husband's works fine when he got the folder from me and mine will not.
Same Problem here, Installed with no issues, and the game was loading up until about an hour or 2 ago. Suddenly I try re loading and it's stuck. Press play on launcher and it's stuck saying "Launching..." nothing happens.... Whats happened over the last 2 hours?!
well i am stuck re-downloading the 8gb...
i've made him open it a few times to see if he still goes to login screen. his is 100% no problem any time he launches. i still can't even get the banner, my launcher just disappears.
@Zohran - so your trying to re download mate?
@ Lovera - That's so strange :S. My banner doesnt appear either... but launcher stays there saying "Launching..." so wierd.

Any Blueposters understand whats going on?
@Dragon - removed all the folders within the diablo3 folder, forced the launcher to re download. see how that goes....
this is my 3rd time re-dling d3. -.-
bump...pretty silly...response please
bump
on my second DL now... still having this issue
05/14/2012 07:59 PMPosted by Zohran
well i am stuck re-downloading the 8gb...


I know that feeling
i'm going crazy, i've copied over just about every folder of his that could possibly be related just in case, launcher still says game is up to date, i hit play and launcher is gone and nothing happens. i have no idea why my folder works for him but not me. guess i'll try reinstalling. very frustrated.
Same graphics card too...
bump
Well, I just decided to uninstall the game and try reinstalling it since I still have the installer downloaded, i never removed it.
I'll let you guys know if that fixes it for me or not, I wouldn't count on it though.
I'm having the same problem. I haven't tried reinstalling yet because I had to go to work. I'll be home in an hour and will try to then if I don't see a solution. I did have some errors with the updater crashing, but after restarting a few times it finally worked.
Don't hold your breath for blue posts... Blizzard techs don't know any line of actual technical support besides... "Reinstall the game, patch... and try again."

Join the Conversation

Return to Forum