Agent.exe not running correctly - stuck at up

Technical Support
Hello,

I have tried every solution I can find on these boards (and the EU boards) including stickies etc, and I am unable to even begin the installation process, as it hangs on 'updating setup files and then tells me that agent.exe is not working.

I am trying to install from a disc to a windows 7 machine.

Please help
Gl, seems alot of people have been having this problem. some people have found answers in other threads but none have worked for me.
This problem with agent.exe has been around in several betas and blizz doesn't seem to care.
I couldn't play the beta either.
Looks like i will have to contact customer support and annoy them until they give me a refund so i can go buy the game cd and install it.
Well, disable or uninstall any security software or create necessary permissions by adding all the diablo related executables to the whitelist or exception list whatever they call it. Also try directly connecting to your modem if you have a router.

Try deleting the blizzard entertainment and battle.net folder from c:\programdata and try the launcher. If that doesn't work, create a new windows user profile with admin privileges and run the launcher from the new profile.
- Delete your battle.net folder in programdata
- Right click the "Diablo III Setup.exe" and go to properties
- Go to the "Compatability" Tab
- Check the box "Run this Compatability mode for:"
- Make sure that the mode is Windows XP (Service Pack 3)
- Apply, then right click the Setup.exe again and "Run as Administrator"
- Check you have a Diablo III.temp folder and a shortcut.lnk folder on your desktop, IF THESE ARE THERE AND PROGRESS IS 0% then it is installing. WAIT UNTIL the shortcut and the Diablo III no longer have .temp on them, and then close the installer.

- Go to youtube, search Epic Sax Guy (10 Hours) and rock out (it takes a good time to install)
I actually just got past the updating files to the installer after some tinkering and another reboot, the method which seemed to work was
As I posted above, (this is Havok) I had the exact same issue. These are the steps I took to fix it:

0) Set Diablo III.exe and Diablo III Launcher.exe (in your diablo install folder) to 'run as administrator'. (Right click->properties->compatibility->checkbox)
1) Delete C:\Programdata\Battle.net (the entire folder!)
2) Run diablo III's launcher, wait for the patch to fail due to the agent.exe error
3) Run C:\Programdata\Battle.net\Agent\agent.exe
4) Run C:\Programdata\Battle.net\Agent\Agent.524\agent.exe
5) Run diablo III's launcher, wait for the patch to complete (~3 minutes or so)
6) Run the game.

Join the Conversation

Return to Forum