Launcher pops up, press PLAY is not launching

Technical Support
Prev 1 9 10 11 20 Next
It worked for me last night but now I'm stuck at the launch button. Guess it must be a server issue
why are ppl saying bump, whats that?
Just to confirm....are we all talking about the install going fine, get to inputting user name/pw..and you do....but the 'play button' never gets active?

If so..sign me up..two in this household having this issue.
Bump is the act of of putting a thread back to the top of active threads, since they are listed by the last person to write in it. Me replying to this thread will put it back to the top in hopes of it get addressed, or replied too, by someone who can.
I was having the problem where the install went fine, the beta worked fine, and when I go to press "play" after I use the launcher and it says "game is up to date", then it does nothing. My cursor will load for about 3 seconds then nothing at all.
Just to confirm....are we all talking about the install going fine, get to inputting user name/pw..and you do....but the 'play button' never gets active?

If so..sign me up..two in this household having this issue.

You get to input your PW and NAME? this thread is not for you then, read it again. People posting here are not getting past the VERY first screen. For the majority of us in this thread we were UNABLE to even get to login screen. We basically complete installation, and there's where it ends. Seems to be an issue with Agent.exe conflicting with launcher.exe. Anyways, in my case and many others, once we push play, we see Diablo's skull in the center of the screen, and that's the end of it. The game as the title says does NOT launch past the launcher. It simply does nothing past the skull.
Yeah. My game installs fine, but once I press play it just sits there at 100% and never goes anywhere. I'm hoping it's due to the servers being absolute trash right now.
above post is spot on

if you got past the Play button, you have the function of this post beat and should search forums for your specific problem
i can't even get that far i uninstalled and reinstalled twice and have the issue of clicking play and get the message Diablo III has stopped working oh what fun i'm having with this game
ya sometimes the application picks up, diablo3 launcher and .exe both seem to be using CPU juice while Agent does not. (from watching Task Manager all day :(

although nothing pops into the system tray like a newly started game program would.
Make an Admin account. I tried absolutely every other crazy solution and this was the one that finally worked. Good luck, it's an amazing game and you will play it eventually.
It may be one of their updates during the day that everyone dowloaded changed something in the launcher which causes it not to start. Same thing happened with Biowares SWTOR launcher after an emergency update that was put together a bit too quick.

I am trying not to get my game close down so i dont have to go through any launcher updates :p they seem dangerous at this point.
I am going to give you guys a little description of what I have attempted so far, thus saving you time.

I got the game at Midnight launch and have NOT played a single minute, with the same problem since then.

I have since then attempted to
1. reinstall windows
2. format my hard drive
3. reinstall all drivers
4. Windows updates
5. change my firewall settings
6. uninstall my anti virus
7. Uninstall/Reinstall the game from CD-rom
8. Uninstall/Reintall the game from online download client
9. Run as administrator
10. Chance setting to Windows XP 2, XP 3, etc etc
11. Close agent/launcher/diablo in the task manager
12. Reboot my wireless router/internet
13. Tried EVERY single gimmick some clain to work in this thread
14. I could go on and on.... just wanted to give you guys an idea.
Bump again.

I've had this issue on and off and for the life of me cannot decipher what the cause is.
It seems to be system specific, considering some have the issue, some don't. I have other systems here that never have the issue.
found a couple forum links that have some useful info in it.......didn't help me but maybe someone else will benefit

understand that servers are down for now though

the goal for this thread is to get to the log-in screen/cinematics etc.

this should be number one 'achievement'
So I just got mine to work again..

It seems when it doesn't want to work it'll say it's updating files, always the exact same amount every time I run the launcher. 10,000 odd, I can't remember the exact number.

After it updates them and I click play, the button goes grey and nothing happens.

What I did this time was let it update, even though there's nothing to update and when the play button because available I closed the launcher via the x at the top right corner of the launcher (not via task manager).
I then started the launcher again and it bypassed all "updates" and said game is up to date.
Clicked play, it worked....

Now I've tried that a few times before to no avail but this time it worked..

The fact that this problem is so tempremental makes it rather hard to pin point. It'd be nice if this issue was acknowledged by blizzard as an actual fault in a sticky rather than being left to fall into the archives, never to be dealt with again like they did in the beta when I and everyone else brought up this exact same issue 6 months ago.
Well it's 2+ hours later.. and removing folders uninstalling removing again.. restoring the ones I should have removed from beta (even though I did uninstall), removing them once again, and... and...about 10 other things I did. This isn't my first rodeo with computers either.. I've been around since Windows 3.1 and actually before since I've used dos. I've used 95, 98, 2000, XP, Win 7, a Mac, and I gotta say this is by far the worst piece of software I have ever tried to install.

At one point the forums changed and I couldn't find my posts, then I started downloading a new game client and after about 100mb I noticed it said EU on it because somehow I was on the wron webpage.. Even Blizz website here has been a little screwy.

Now I've downloaded the game client all over and started downloading the whole thing over again. I am struggling hard to maintain my composure but posting stuff like "so and so should be fired" is starting to sound really good.

I think what frustrates me the most is the fact that I had a working beta.. and then when i get the release version it doesn't work. I even made a forum post here about will anyone with the beta have problems installing the retail version before hand. Because I know how computer programs often work.. they often leave pieces behind which screw up the next install.
Hopefully this goes well, but at this juncture short of direct one to one support from a blizzard employee I am doubting this will make any serious difference.
If they don't address this issue directly, I bet they'll fix it in a patch in the next few days. I don't think it's as isolated as it seems. The forums are just flooded with people whining about the servers being down, so threads like this get pushed off of page 1 pretty fast. I'm disappointed that Blizzard wasn't more prepared for launch, but I realize there's nothing they can do about it now (aside from what they're doing). I'm sure this will be addressed, but at the moment their concern is fixing the error affecting the largest number of people (the servers being completely down). Once the people who can get to a login screen, they won't be screaming in the forums anymore, and Blizzard will be able to address this. I've been able to play a little, but this error seems to randomly pop back up for me. I can't pinpoint what makes it resurface. It popped up one time when I tried to boot with my usual programs again. I disabled the startup programs in msconfig, rebooted, disabled Norton AV, deleted the Updates folder, and kept killing and restarting agent.exe and the launcher in every pattern I could think of. I don't know what finally makes it work after a while, but something I'm doing finally seems to get me to the point where the skull pops up and the game loads.

Join the Conversation

Return to Forum