Need some Help -"Below Minimum Specification"

Technical Support
Long story short.

A problem came up just today where my only option was to wipe my computer completely. I go to redownload D3 afterwards and I get the message:

"Below Minimum Specifications"

"Diablo 3 requires a new operating system"

Uhhh, what? I played the beta perfectly fine with zero problems. On top of that, I pre-downloaded Diablo 3 today, before I had to wipe my system.

Any ideas?
Updates

Join the Conversation

Return to Forum