Stuck at 0%

Technical Support
I use the installation disc and the game says installing and just stays at 0% I also tried the DL client from Battlenet and it stays at 0% also, any help here? NOTE: Im running windows vista if that helps at all
05/15/2012 02:34 AMPosted by ScottieSlice
NOTE: Im running windows vista if that helps at all


Found your problem.
Right-click the installer and run as administrator.
There is nothing for me to right click. When i put the disk in it just says run and then goes to the screen that says install.
Continue to Local C drive. ProgramData/Battle.net/Agent/Agent.952 and set that to RUN AS ADMIN. Make sure your Diablo Installer is also set to run as admin. You dont need to set the compatibility for running as a specific Service pack.. only do Run as admin.

This is for Vista..
For Windows 7.. go to C:\Documents and Programs/applications/battle.net/agents/agent

(Not sure if this is correct but find that Agent program and run as admin!!!!)
Make sure the Agent application and Diablo 3 Launcher/installer are both set to RUN AS ADMIN
I only see an Agent. 524 and 954, No 952
Have you made sure you have the latest service pack? Mine wouldn't install on vista coz it needed updates
Where would i go for the latest service pack?
Same problem =(
Give up.

I've been trying for 5 hours to get this running under vista sp2.
Have tried everything in this forum and then some.

I'm going to bed. You should too.
Im considering sleep, but that just means ill delay the problem till i wake up. Id rather get it taken care of now and then sleep lol
Any other help?????? anyone?
Dont bother most of us have been trying to deal with this issue for hours there are no solutions wait for Blizzard to get off their !@# and fix it
I think i might cry
if you have troubles with Diablo 3 setup being stuck at 0%, deleting any diablo folder in C:\ProgramData\Battle.net\Setup may help.
My OS is server 2003 enterprise which is the same as XP x 86/ XP 32 bit.

First fix, if you are stuck on updating then you need to go to C:\Documents and Settings\All Users\Application Data and delete the battle.net forlder.

Once you get past that then you can install the game. Unfortunately, for XP users you may get stuck on 0 percent install and the game will not install.

To fix this I had to take an unconventional method but it worked for me. I basically had a laptop with windows 7 on it. I installed d3 there and then I took the C:\Programs\Diablo III folder and copied it to a portable hardrive. I then transferred the folder onto my server's c: drive into the programs folder and ran it.

I know this is not the greatest fix but it works perfectly. To blizzard coders. Why do we need to introduce coding which blocks people from installing on a legitimate OS. This code is extremely annoying as its only purpose is to prevent installation. If it installs and works then good. If it installs and does not work then darn. Please at the very least, let it install.

Here is my thread.

http://us.battle.net/d3/en/forum/topic/5051955482?page=1#0
Ive deleted everything and started fresh and still gets stuck at 0% Ive ran as administrator also and nothing
Try Fix 4, Worked for me,

http://www.keenandgraev.com/2012/05/12/diablo-3-stuck-updating-setup-files-fix/
dont worry, even if u get the installl running...
you cant play because the servers are Down.
I'm having the exact some problem with a Windows Vista. Have tried just about everything and it just stays at 0%.

Join the Conversation

Return to Forum