Screen Turns Black and alt tabs me out.

Technical Support
Prev 1 19 20 21 38 Next
I solved this problem on my machine with a combination of enabling v-sync and downclocking about 50 MHz on all clocks.

i7 920, 9800 GTX @ 1680*1050, all settings high.

It gets hot (85C or so), but I'm told that the reference design is spec'ed for 105C max, so I'm still within safe limits. I'm guessing that there's probably a bug in one of their shader programs. Maybe without limiting the framerate or knocking the clocks down, there's some buffer overrun happening. Hopefully they can fix this soon.
same here any news?
I have a 250 gts and updated my driver and set the game at about 60fps and haven't had a problem with more than 2 hours of play time. I'm thinking they might have fixed it.
So far nothing has worked for me. I have a 9800 GTX+ underclocked to about 640 now, fps set to 60, everything is on low. Granted my GPU gets pretty hot, this is the only game that causes this problem.
Bump for great justice!
I've posted a fix for this for people who use Geforce cards.

us.battle.net/d3/en/forum/topic/5150106459?page=1


Worked for me!
Genius who ever found this out.
Nobel Peace Prize for quenching all the nerd rage from this!

GeForce 9800 GTX/9800 GTX+ btw
Hate to say it but the downclocking worked for me and my 9800GTX+. That and I took the in game fps down to 50/10. Those two things and I am in business until they fix this game.
Downclocking solved it for me as well. The only other thing I did was decrease the resolution slightly so that the performance doesn't suffer (better FPS).

Still waiting for a legit fix from Blizzard though, I wanna play the game at the maximum of its potential! :)
We worked on this for a while with my girlfriends computer, which has a Nvidia GTX 460, and we solved the issue (so far) by under clocking the GPU by 200 from 650 down to 450, and setting her fan to automatic.

The card's not running above 70 Degrees Celsius, and we haven't had a black screen skip since. However, the problem is that when she plays WoW, her card often gets to 70 or higher, and we never have the issue of black screening constantly (save for perhaps one display driver crash once in a blue moon, but that's been referenced to be an issue with WoW and the card in general, not an actual over heating issue).

So yes, under clocking does seem to work as a temporary fix, but the idea of having to under clock a high performance video card, even if it is a few years out of date, is credulous to play a game. However, this does seem to verify the issue is caused by making something in D3's graphics engine making the card have issues once it reaches over 70 degrees when using a fan.

To compare, I have an ATI Radeon HD 5800 Series card with a liquid cooling system, and I've yet to see my card's heat go over 40 Degrees at any given time while playing D3, with all settings at high, and max Foreground FPS at 150.

So yeah, there ya go. The best comparison and information I can give on the subject right now, just hoping this does get read and looked at by Blizzard so that players with the GTX series of Nvidia cards don't have to resort to constantly under clocking and changing their fan settings every time they want to play Diablo 3.
Down clocking everything by 50 solves this problem for me.
05/18/2012 03:20 PMPosted by Thraim
Down clocking everything by 50 solves this problem for me.


Same here.
Unfortunately, I've had to under clock by about 200, as well as entirely turn off my shadows and turn my fans up to auto/full (which is about 70-100%) speed. I also turned off anti-aliasing, and have only had one freak crash in the past 3 hours. The game quality hasn't been reduced too far (overall) but I repeat:

THIS IS NOT A FIX!

High performance graphics cards (as listed on their compatible cards page) should NOT have to under clock! All other graphically intensive games work perfectly on standard settings, and this isn't half as detailed!

I've also noticed that the crashes are more common when finding health wells, unique mobs, or bosses...Anyone else have this trend?
it didnt work for me ....
Downclocking helped me too. I was even able to turn all the rest of the settings up and everything is still working! Thanks :)
work for me as well. wish they could jast admit they need a fix.

9800 gtx+
Hey all!

We (Blizzard and Nvidia) are looking into this issue, and we'd like to get some heat numbers from you so that the engineers will have a clearer picture of how things are breaking down. To check where your heat levels are at when the blackscreen occurs, please follow the below instructions. Once you have the number, please reply to this thread with the following info:

Operating System -
Video Card Model -
Driver Version -
Max Video Card Temperature -

Thanks!

Heat Monitoring Instructions

1. Download and install any Hardware monitoring program such as CPUID’s Hardware Monitor: http://www.cpuid.com/softwares/hwmonitor.html
2. Startup up the Hardware Monitoring program.
3. Expand the section you want to see (Video card in this case).
4. Start Diablo III in Windowed mode, and move the windows so you can see the Video card temperature while Diablo III is the active window.
5. While playing Diablo III pay close attention to the temperature of the video card.
6. Write down the max video card temperature.

Alternative: If your computer only blackscreens in Fullscreen mode, just start up the monitoring program before you begin playing, and after the blackscreen occurs alt-tab back to the monitoring program and check the maximum video card heat level.

**Note** Each video card has a different temperature threshold, and where one video card may black screen at 80c, another may black screen at 100c.

WORKAROUNDS
After you get the needed data, try switching on Vsync and dropping your "Foreground FPS" to 40 in the options menu. It doesn't work for everyone, but it may help some while the engineers work on the issue.
Nvidia GTX 465-

Standard temp in Celsius- 40-47*C
Temp while playing D3- 70-72*C

Note- Video card ONLY blacks in D3 when at these temperatures- Other games handle the 70*C temp just fine, including World of Warcraft.

--------------------------------
Recap-

Crashing with-
GPU Clock set to 625 MHz, and fans set to 40% during crash. Temp 70*C

No Crash-
GPU Clock set to 425 MHz, and fans set to auto (70%) prevents crash. Temp still 70*C
How do you downclock? I have NVIDIA control panel up, but can't find the option. I have a GTX 260
05/18/2012 07:41 PMPosted by Trelliw
How do you downclock? I have NVIDIA control panel up, but can't find the option. I have a GTX 260


I have an EVGA precision X panel for my Nvidia:
http://www.evga.com/precision/

- In the center of the screen I lowered the 'GPU Clock' Function. It seems to have worked temporarily. Drop it 100. If no results (mine crashed not 15 minutes later) reduce by 200. Frame rate and such 'should' not need to be reduced in game. I also changed my fan curve settings (far right bottom corner) to 'auto' which adjusts my fan as needed with the card instead of staying at a set speed. It can get loud, but it keeps the card and game going.
Thank You, I will try that.

Join the Conversation

Return to Forum