Technical Support
Did everything told me, ran a system check and did a defrag. I deleted the file and everything. Cannot figure this one out.
Exact same thing here.
Same issue.

I was running the game, and it stopped working for a extended period of time. I could still move move the mouse, and number lock toggled. I could not however minimize or end task on D3. I did a hard reset.

I'm running a mirrored RAID array (RAID-1). No drive failure have been recorded, and I've an excess of 100GB left. I've encountered no other problems other then D3 refusing to launch.
Same issue here. went out bought the game and tried installing it and got the BLZPTS00009
error. I have over 300GB of free space on my drive.

I did all the help section said to to do, scan disk and defragment (drive is only 2% fragmented so didn't really do, but performing now).

Glad I'm not the only one with the problem but I hope we get an answer soon.

edit: just found this
I should point out two other things before and after I uninstalled D3 in case some little detail got corrupted along the way.

1) I've no other problem writing large files to the drive before and after the uninstall.

2) Blizzard doesn't clean up it's registry entries on uninstall.
Thats part of the agent.exe error right? i found the agent updater and updated it and it fixed it.
Its under in program data
Where did you find this updater, need details. Running Windows 7 and have the game on DVD, and getting the HD space error.
Thats part of the agent.exe error right? i found the agent updater and updated it and it fixed it.
Its under in program data

Yea, where is it? I keep finding more stuff the uninstall left behind, and trying to reinstall again. I keep getting the same error.
im using vista.
here is the path file for me
Remember that program data is a hidden folder. Inside Agent there are a couple more folders that say Agent. i clicked on the .954 agent folder and used that updater. There is another updater in the other folder.
Im unsure on the difference. All i know is i dont have that error anymore.
It's in the same place for Windows 7. That trouble shooting step would have been awesome to include in the official version. (Before I thought the whole install corrupt and uninstalled D3!)

Thank you for the clarification. :P

To be more clear, the 'Agent' executable in the root folder. Not to be confused with the other executable in that sub-folder. The game works now. :)

The full path being: C:\ProgramData\\Agent\Agent.exe
your welcome. Yea i know haha. I tend to do this kind of stuff xD i love how literally nobody posted about this fix in the 2 1/2 weeks since the problem started xD
Dude i feel ya i have over 800GB free and this thing is telling me it's a no go.
update the agent and try it then
did and nada me and my father have been working on this problem since i got us the game. We both are outta ideas and have tried attacking this problem from all sources and still nada but ima lay off for a month or 2 or maybe till next year, when it may get fixed.
there has got to be something wrong somewhere
probably a compatibility issue or some hidden setting on something that is getting in the way
or something else that is getting in the way for some unknown reason

boot in safe mode and try to install in that mode..?
This sucks, are there any other suggestions out there?
Ive tried everything you guys have tired with no success. I still get the error BLZPTS00009. Everything starts like the setup part but THEN it stops and gives me that error. Now if i get a refund from them and get another disk will that work you think?
Ive been fighting with this Error since release. and waiting with annual pass since like dec. The direct me to the forums and ive tried everything. I didnt find the Agrent file in my task manager. Now they decide to leave tickets unanswered over 24 hrs. I can stay im getting pissed. and ive been a customer of theirs for about 5 years now. Im Really unhappy with their conduct
Go to start menu
scroll down to secondary login
right click secondary login
set to automatic

this fixed the error for me

Join the Conversation

Return to Forum