Lag issues

Technical Support
Hello, I am able to install and log in to Diablo 3 but when I play the game its all so very choppy and lags alot. The response time when issuing commands is several seconds and my characters only moves a short sprint every few seconds as well as enemies. I am positive my system meets the requirements as I researched beforehand. Is there something I am missing? Any help would be awesome, thank you!
im having the same problem but it seems like no one want to address this. Its vary hard to get far in this game when all the enemies just appear in front of you and your guy just tippy toes around
I too am having the same problems. I know that I meet the requirements needed for this game (and then some) and even tried un-installing and re-installing the game. That didn't seem to do anything.
Yeah me too. I know my Pc meets all the requirments and it can run BF3 on the highest qualily. But when I play it just lags up and the character mooves slowly, the enemies walk and then teleport and deaths and movement is in slow motion. Is it the game? the severs are just to packed or my computer?
i wish an admin or someone could tell us if this is a server issue or what.
Yeah me too. I know my Pc meets all the requirments and it can run BF3 on the highest qualily. But when I play it just lags up and the character mooves slowly, the enemies walk and then teleport and deaths and movement is in slow motion. Is it the game? the severs are just to packed or my computer?
I think its because of the way Blizzzrd made the game they didn't let it support many graphics cards. I believe there was a list of 700 cards that didn't make the cut. I think that is out problem because i have a top end computer that still can't run this game. Hopefully they patch it because who pays for a nice laptop to play on the lowest settings.....
Please remember to check your internet refresh rate and such.

Note: I had a similar issue when testing the closed beta. Though, now it seems to be running smoothly. IMO: it's due to clutter on either end, be it user or blizzard I'm not sure.
its like every monster is elite and has teleport lol
really? the game doesnt support many graphic cards? thats just stupid. they should really patch that up quickly.
did they do it like that on purpose?
Yea im having the same problem, brand new laptop and its choppy and laggy as.

Unplayable and bitterly pissed off right now

Join the Conversation

Return to Forum