Installer stuck at 0%...

Technical Support
Am i the only one stuck at 0%? i went to the midnight launch and everything and cant even download the game =\
Same man, its so fun hearing the music for like hours and then seeing its still on 0% i lie mine stopped at 1%
It could be a port or firewall problem, try looking for something down that alley.
Also when making a thread, call it something else than just "WTF.." blues or helpful people really can't see what your problem is when you name your thread the way you do.
if you look over at the starcraft fourms people are having issues with patch 1.4.3. since i decided to put starcraft 2 on the machine for something to do, since i was waiting for d3 release to happen. i was able to download the game however when it tried to patch it seemed to have issues. so i tried to download the standalone patch 1.4.3... and it failed to. so i searched through the fourms, and one recurring theme was showing up for windows 7, att as an isp, and trying to patch:

people who were trying to patch were having to get someone they knew to provide them with the standalone patch so that they could play sc2 at the current patch level.

thus, when i had the same issue with d3 and the same server popped up as did for sc2:

attdist.blizzard.com

i connected the same machine to an alternate isp (comcast in my case) and presto, problem solved. game installed in mins.

i'm not saying this will help all of you, but maybe it will help some. i just wish that blizzard and/or att could work this out... because from going through the forums it appears this has been an issue for months for the sc2 people.

Join the Conversation

Return to Forum