error 3006 shield bug?

Bug Report
so there is this error 3006 with connection timing out.

but i notice many people are refering to an obscure bug with shield swapping with templar / demon hunter or something...

i was playing the game, and i did actually just equip a new shield to the templar.

but then i noticed it was better than mine, so i switched between them by dragging my demon hunters shield into the templars slot, assuming it would switch.

the game froze completely. i had to alt-f4 to get out.

and since then i can not get in.

what should i do ?
Yep happened to me too.
i found a solution. i play on different zone. i was on europe now i switched to america.
I tried and it says i don't have a valid key.
I am pretty sure this creates a cache issue (thats why a different zone fixes it, different zones use different caches). If you reset you router it should reset your cache.
I'm having the exact same issue and it arose from switching shields from my templar to my demon hunter.

I'm attempting to reset my cache, however I live in an apartment and don't have access to the building's wireless router.

Any tips on how to fix this?

(switching timezones lets you play but is not a fix, btw...)
I've tried everything i can think of, including unhooking and resetting my router and clearing my DNS cache. Still stuck getting error 3006 after it goes to retrieving hero list. Anyone find a solution?
Yea same here have done router resets computer resets just about everything I can think of a band-aid solution is badly needed here.

Would be great if a forum moderator could jump in and let us know if they have made any progress on this my entire 4 man group is currently locked out of the game
Come on folks -- can you reset us that are locked out pls? This bug nailed me as well.
how on earth does a bug like THIS make it through all the beta testing and whatnot. i've been waiting longer than anyone i know irl to play this and here i am sitting infront of a screen that DOESNT have d3 on it... so pathetic. this should b fixes ASAP. geez
Annnnnnd another one is caught with this bug.... :(
Has the whole reset your router thing been CONFIRMED to work? i just unplugged all my wireless getup for 1/2 a minute and plugged back in. still wouldnt get me past 3006.
Hey guys,

A hotfix is in the works and we want to get it implemented as soon as possible. We don't have an ETA for you, but we will try to update you on this situation in this thread and on Twitter.

Thanks!


Posted 15 minutes ago in case anyone missed it. Good news for all!
where was this posted? a link plz ? thx
Glad to see them working on it, but still very disappointing. Guess I shouldnt have bothered taking the day off work hey?
05/15/2012 07:40 AMPosted by SKiTHiRyX
where was this posted? a link plz ? thx


http://eu.battle.net/d3/en/forum/topic/4078817846?page=29#572

For whatever reason the quote code wont show that it's a Blue post here but will in my other thread.. weird.
Same error here.
Always get 3006 error. And i can log in to american servers.
But i want my WIZARD :)
i DID take the day offa work and so far i'm upset by my loyalty. i hope this fix comes fastest possible or my day would practically b wasted.
Happened to me too. And I concur with SKiTHiRyX. Took days off from work to play. Now I'm sitting here looking at an error message.
and it's not like i'm gunna go do something else for 4 hours now... cuz i wanna b back on the second i can be again. makes me wish i just left the damn shield alone.

Join the Conversation

Return to Forum