Stuck at 30% Updating Setup files.

Technical Support
I'm using Windows 7 64-bit. I've tried both a digital and disc install. I've deleted my battle.net folder multiple times. I've tried ending Agent.exe in task manager and every time I do it instantly comes back. I've tried firing up agent.exe then the installer. I have secondary logon enabled. Firewall and everything is down. Only version of Agent I have is Agent.524. No copy of Agent.913 in my battle.net folder. I'm at my wits end.
This is exactly where it's hanging up on.
http://i.imgur.com/69Kyg.png
Same issue here, except mine is getting stuck right at the end. This started after deleting C:\ProgramData\Battle.net and ending Agent.exe in an attempt to fix:

ERROR: The file "c:\Program Files (x86)\Diablo III\Updates\d3-09558-Win-final.MPQ" appears to be corrupt. You may need to download this file again.

Deleted the file in question as well. Not sure what to do now.
At least that's something. I have it running in Windows Service pack 3, admin mode. The whole forum recommendation shebang. Still nothing.
same here. stuck as a duck.
I'm guessing that Blizzard has not figured out Windows 7 64 bit. I really don't want to have to install to XP.
there is a stick post about making sure secondary logon service is enabled; but that didn't help me
i get to about 60-70% and it stops no luck as well :(
I have windows 7 32 bit, and I am having a similar problem, if not the same one.
AWWWWWWW BILLY I GOT IT TO WORK
Go here: patchup.info/d3/tools/Win/

Download these 2:
Diablo III/WoW MoP Launcher
Diablo III/WoW MoP Update Agent

Run the installers, then run the Diablo 3 installer. Just worked for me.
vista stuck as well about 70%
Same here. Have tried doing several things with no success. Some times it gets stuck at about 95% and other times 30%. I have no idea....

Join the Conversation

Return to Forum