Pixelation Lighting Effects Fix ATi HD Series

Technical Support
The fix worked for my HD 3800 but the rest of my computer seems a bit unstable. I'm getting Driver Crashes when I'm wacthing youtube. I don't like this...

Either way, ATI or Blizz should make this one of thier higher priorities to fix. This is clearly affecting a lot of people. Using a two year old Driver to fix a modern triple AAA title is extreme.


Yeah Ive noticed these things too, and it is quite frustrating, Im really hoping this is resolved with the 12.5 release from ATi.
.
Hey guys,

I'm wondering if anyone can help me please.

I started playing a day or two after launch, when the issues were at least semi-fixed and the EU server occassionally let me play. I was using my laptop with its ATI Mobility Radeon HD 4300 (or is it 4330, I don't know, it's 250mb I think) and I had drivers from March 2012. Everything worked great graphics wise. I updated my drivers as advised to to the most recent, which I think was April, I again updated them early last week to the newest version from May, 12.4 Catalyst I think. Everything worked fine.

Today I installed something via Windows Updates, it came up with 4 framework 3-4 updates and took a good 20 minutes to install them. I also installed the Witcher 2. When I restarted my machine and next tried to play D3, I experienced horrible graphical issues.

All over the screen certain things, like my boots, were smudged. I had grey triangles all over the screen and the chat window was unreadable and looked like a load of squiggles from a pen.

I uninstalled all ATI drivers and software including CCC and rebooted. I also removed the Witcher 2 because it would not run smoothly. I reinstalled the 12.4 software from the AMD website and rebooted again. The issue remained. I uninstalled it all a second time and installed the 12.3 software, it did not install correctly (although it did not error), and my device manager and screen still reflected basic VGA drivers. I uninstalled and reinstalled old drivers 4-5 more times and each time after rebooting the laptop remained at the VGA settings and did not reflect the new drivers.

I decided to check the Dell website. This is horrifically out of date. Even though it can scan your system it always says that the most recent drivers available are from 2008-9. So I installed some drivers from 2009 and it updated my computer to CCC and device manager reflected that it was ATI Mobility Radeon HD 4300 and not the VGA chip set thing. The graphical issues were gone from D3 WHOOPEE! The only issue is these drivers are 3 years old. I want to try and use the ones from March 2012 that I used previously without issue. I can't get them to install again though.

I hate CCC, unless I'm missing something it has no driver search features. Every time I search for drivers it insists I install CCC which then just sits in my bar with no driver support options.

In the previous threads about issues with 12.4 catalyst and raedon's, the 4300 series is not in the affected or unaffected lists, but I had major issues. 12.3 worked fine but won't reinstall after full clears. I tried the hotfix and it did not fix the issue.

I'm a technophobe btw, this all took me 12 hours and really frustrated me.

Thanks guys!
Has anyone tried the 12.6 beta drivers?
I have try the 12.5 beta's and the 12.6 Beta's as well, problem still presists. AMD also announced recently that they will no longer be doing monthly driver releases instead they will take as much time as they need to produce a new driver and release when they feel its best, so it could be a few months in between releases now Oo.

The 12.6 Betas however were only first release ones 12.6a's I will be sure to try any and all new betas they put out in the hopes this stupid problem gets fixed.
Not sure if you guys are aware, but they have a hot fix driver out again. Version 12.4b

"We’ve recently identified an issue where some of our legacy graphics products are producing certain artifacts in Diablo III and The Elder Scrolls V: Skyrim with our latest release of AMD Catalyst™ 12.4. This issue affects users of ATI Radeon™ HD 2400, 2600, 2900, 3400, 3600 and 4500 graphics cards."

12.4b will fix the issue mentioned in the quote :)

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst124bhotfix.aspx
05/27/2012 04:35 PMPosted by BoredStudent
I hate CCC, unless I'm missing something it has no driver search features. Every time I search for drivers it insists I install CCC which then just sits in my bar with no driver support options.


Hi, this link should help (I have it bookmarked on my toolbar because I'm crazy like that)

http://sites.amd.com/us/game/downloads/Pages/downloads.aspx

Also:

http://twitter.com/@catalystcreator
http://twitter.com/CatalystMaker

These feeds are handy when you are having trouble with a particular game and want to keep up to date with progress on the fixes :)
Not sure if you guys are aware, but they have a hot fix driver out again. Version 12.4b

"We’ve recently identified an issue where some of our legacy graphics products are producing certain artifacts in Diablo III and The Elder Scrolls V: Skyrim with our latest release of AMD Catalyst™ 12.4. This issue affects users of ATI Radeon™ HD 2400, 2600, 2900, 3400, 3600 and 4500 graphics cards."

12.4b will fix the issue mentioned in the quote :)

http://support.amd.com/us/kbarticles/Pages/AMDCatalyst124bhotfix.aspx


I try'd the 12.4b drivers when they first put them out sadly they didnt not fix the pixelization issue on my HD 3800 I do not know if that driver verison fixed it for others or if they are referencing another issue entirely. calling it an Artifact in video card terms is kind of vague lol
Worked flawlessly on HD 3850. Thanks very much
i have a hd3850, running 12.4 drivers, didnt even apply the hotfix, and i don't see any stray pixels or pixelation on lightning effects. strange. i suppose now that you've rolled back you can't provide a screenshot. oh well ;p

edit: maybe its related to other hardware in the system, but maybe you could try updating your directx? ;o newer driver sometimes tend not to play well with older versions of it, and vice versa.
Any experiences as to whether 12.4b fixes the issue?
Yeah, I have this issue with the Ati HD 2600 Pro. I have installed the 12.4b patch and it didn't help at all. Guess I am gonna have to try 10.9...

EDIT: I used the uninstaller from the Install Manager and removed the CCC. Then I went to the video card and totally uninstalled it. Once that was done, I reinstalled the 12.4b patch, restarted my computer and everything seems to be running smoothly now.
Thanx my pal... let`s see how work this rollback drivers!!! See ya... they care!!!

SirLachdanan.
Added new fix using latest drivers for best possible results!!

Also AMD has put out some changes to how they will handle video card driver updates, you can read this in the article all on the first post.

Enjoy!
the most frustrating on this is the reappearance of certain bugs after +2 releses.12.3 pixelerrors - 12.4-125b=okay now wow forced me to 12.6 --> pixelerrors again ... why do these bugs always reappear? im relly fed up by now to have all this driver-terrorism ... every major patch of wow and i have to update all drivers to get wow running, and when wow works - d3 does most certainly NOT work at all.

think this is a pixelshader-desk/game resolution error, cause "some" resolutions work fine with few refreshrates.

Join the Conversation

Return to Forum