ATI Mobility Radeon HD 3650 - Graphics Issues

Technical Support
So I am having (sort of) similar problems as other people with the gray graphics issues/gray triangles. Here is my situation:

- Had the 12.2 Catalyst drivers during the open beta weekend. Everything ran perfectly, full resolution, full textures, anti-aliasing, etc.

- Updated to the 12.3 Catalyst drivers.

- Uninstalled the beta entirely, installed a retail version of the game from CD.

- Menus all look perfect.

*Issues start here*

- When I go to load the first game, the "loading splash screen" is very "pixelated" and poor looking (which later I realize is the first failure indicator).

- Almost all of the graphics are gray and jagged, except the 2D menu bar at the bottom which is perfect looking.

- When I open the video options menu, the game *looks* fine in the background. I can switch resolutions, which works as far as changing the resolution goes, and the image looks fine still in the background.

- When I close the graphics menu window with the new resolution setting, the graphics are still grayed/messed up.

- Almost all video settings have no affect, other than one of two things: 1) setting the "letterbox" mode, or 2) going into windowed mode.

- While in either mode, the grayness is gone, however, other things (which I'm assuming were/are "sprites"; e.g. flames and background moving things) are pixelated and messed up.

- Performance in both modes is severely affected, but it *looks* playable.

- Read the forums, found out about the driver issues.

- Installed the 12.4 Catalyst drivers.

- With these drivers, even the in game menu in the game has the "Gray triangles" problems that others are describing. No matter what is changed, video setting wise, these never go away.

- Applied the 12.4a Hot Fix from ATI. This hot fix did absolutely nothing.

- Reverted to the last installed driver (via the windows hardware manager for the video card) which is 12.3.

- Graphics are back to the way they were (grayed everything/only working in textbox).

- Tried installing the latest DirectX software.

- Ran the game, this time though, the loading splash screen was not pixelated! When the game came up, the graphics were perfectly fine.

- The only thing that I noticed was that the performance was a bit dogged...So, I changed some of the video settings.

- Graphics went right back to the gray crap. No matter what I do, can't get it back to the same instance when it was fine after installing DirectX.

So that is the point where I'm at, nothing seems to be working. Anyone have any suggestions? I know there are a few things saying I should revert to really old drivers, but I am having trouble finding them....
Alright I figured I'd post here being that I had a lot of testing and experiementing attempting to fix this same issue.

What I ended up doing was, Uninstalling the graphics card (Through the device manager) Then running a driver sweep(Google it, AMD tends to leave pesky trail of their drivers around). Do a reboot and install drivers 12.1 (You may be able to pull off 12.2 I didn't try those, but you said you did have success with them in the past.). After the install do another reboot for safe measure, run the game and hope for success!

PS- For older drivers check guru3d.com For Catalyst stuff check here.

http://downloads.guru3d.com/Videocards---ATI-Catalyst-Vista---Win-7_c31.html

I didn't have quite the success that you did though I could only run mostly low settings to get smooth gameplay. I'm running a Studio 1737, what about you?
I am this very issue. You perfectly described problems i am having. Although I thought this could just be occurring on diablo however it's not for me. I have tried a few other games and got a strange jagged shapes that fly across the screen, and character models seem to be messed up too. I have had this since updating to the 12-4 drivers, and was wondering what to do.
I hope it's reassuring others have a similar problem to you. I know it is for me.
Raze did you try to revert back to 12.1 or 12.2 drivers? That fixed my issues.
Thanks for the help, Cloverz7. It is finally working. The thing I was doing (or wasn't doing) was not performing the driver sweep. ATI sure does like to leave a mess and for some reason it seems as though it always tries to recover from the "last good driver install", despite if you tell it to or not.

Raze, trying using this software to wipe the drivers:
http://www.softpedia.com/get/Security/Secure-cleaning/Driver-Sweeper.shtml

And for the actual drivers, I used the 12.2 (since the 12.1 drivers would error out for some reason when trying to install). They can be found here:
http://downloads.guru3d.com/AMD-Catalyst-12.2-Win-7-%7C-Vista-32-bit-driver-download-2871.html

Note: those are for Windows 7/Vista 32 Bit. Obviously, get the 64 bit ones if you are running on a 64 bit processor.
I'm experiencing the same problem, but when I uninstall 12.4, do the sweep thingy and then reboot, then once I'm back in windows I have the standard VGA-graphic card installed instead of Radeon 3650. There's an error so the resolution is very low.

With no ATI Catylyst installed I then try to install 12.1 (also tried 12.2 and 12.3), but after the install nothing happens even though it seems to have finished correctly.

I've also tried to uninstall the VGA driver, but still when I install again nothing happens. It only seems that I'm able to install 12.4 and this is through the auto detect. After this my screen looks correct, but not when using Diablo:(

I would really love some help regarding as I'm lost for ideas. Hope you have some advice?
I had to manually install the ATI 3650 driver through have disk in device manager. 12.2 resolved the issue for me. Running dell studio 1737 with mobile radeon 3650.
Greyscreen issue with ATI Radeon 3000 and 4000 series cards:

This workaround ought to help though it's a bit of a hassle.

1) Uninstall the currently installed video drivers.
Use a driver cleaner app if necessary
2) Install 2011 drivers (11.5 is what was tested in-house).
3) Ensure the “Disable Catalyst A.I.” is unchecked.
4) Test out Diablo III to make sure no graphical issues are seen.
If not, back track the drivers further.
5) Install the latest 12.3 drivers once again. (not 12.4)
6) Try the game again wth the newly installed drivers, Catalyst A.I should now work too.

____________________________________________________________________
Support Information Administrator
yay!
None of these old packages on 3dguru seem to install a driver!
yea same issue. none of the old packets doesent fit my graphic card. im sure i have 3650 mobility in my elitebook 8530p!
CCC 11.1 solved the issue for me
Thank you Blizzard for providing a solution to this, glad to see at least you guys have good forum support. I searched ATI's site for hours today before finally emailing them this afternoon and was unable to find anything with a solution to this problem. Still haven't heard back on the email (and don't expect to before next week b/c of the holiday) but thanks to you guys I have it working perfectly again. Thanks again!
05/24/2012 12:59 AMPosted by SkunkofDoom
None of these old packages on 3dguru seem to install a driver!


I was able to find the 11.5 drivers here: http://downloads.guru3d.com/downloadget.php?id=2721&file=1&evp=31d5bafeeb3f9ff505ae29cb68f83490

and the 12.3 drivers here: http://news.softpedia.com/news/Download-AMD-Catalyst-12-3-Graphics-Driver-WHQL-261541.shtml
Is there a 64 bit version for the 11.5 drivers?
im having alot of troubles trying to roll my drivers back to 11.5, at first i used the driver sweeper program listed above. and it seemed to work, but when i logged back on and tried to install the 11.5 drivers, the new ati engine control was still there.

So i did the complete uninstall of the ATI software on my computer and i restarted it. When i got back into device manager 12.4 is installed again and i dont have any clue how.

please help.
Can anyone confirm that this issue has been fixed 12.6 update?
12.6 have same issues. trying 12.2.
Catalyst 11.5 did the trick for me on my Radeon HD 3650. i didn't bother installed 12.4 on top of it.

Join the Conversation

Return to Forum