Error Occurred Resetting D3D..

Technical Support
I had the same issue with my ati driver i updated it and still had the issue i rolled back to a earlier driver and it now works fine. try downloading the previous version of the driver
an error occurred resetting d3d i have sins 5 days this problem. i can not play diablo3 and starcraft 2. I need help... i have geforce 540m 1gb .
BUMMMP!!!!!
Im having this problem when im swaping views, with Alt + Tab or Windows Key,,,,, im using Win8 and ATI Sapphire 7970 3gb.

I believe that is something about xfire..... maybe dx is the problem... in Hon i see something like that...
I am getting the D3D issue when I Alt + Tab as well. However, to throw a wrench in the gears, I'm only using 1 monitor on a desktop PC.
i get the gray screen and the same poppup reseting d3d, blizzard, help pls, this had never happend before on your games, are you losing that much quality?
i have the same problem as all previous posts..

i play more or less 10mins. my computer then goes in sleep mode and i get this pop up D3D error message when i start again.
my computer is getting very hot too
Same for me when i'm using ALT+TAB. Please fix this!
Same problem as everyone else, another asus laptop, no desktop screen.
Has this probably seriously existed for 3 and a half months without a solution or even a Mod response in months? That's ridiculous. Why would I upgrade from the trial to the full game if I can't even play it for more than 15 minutes at a time before it crashes, and have no evidence that will ever change.
I have full game (No trial) and same problem. I've tried every solution I've found in the web, but nothing. Win 7 64bits. Ati Mobility 1gb. 8Gb Ram.
I was having this problem and I couldn't figure out what was going on, started after a computer reboot before that had been playing fine. Well come to find out playclaw (similar to fraps) was the culprit. As soon as I closed out of PlayClaw I no longer got the D3D reset error anymore. So if you're running something like Fraps or PlayClaw try closing it out and see if that works.
I am also having the same problem since like 1 and a half months ago. At first the labtop just turned it off by itself. Then I formatted the labtop once, and then I was able to play for a couple of days. But then I'm starting to have this error every single F day. It doesn't only happen when I am on the game. It also happens when I chat with my friends in auction. How can Blizzard not respond to this post for more than 3 months? There are like thousands of people having the same problem. It's sooooooo ridiculous
In D3Prefs changing DisplayModeWindowMode "0" to "1", allow me to play diablo 3
Good Luck People, Leaving the setting alone and play in window mode with out fullscreen seem to work very well.
where is D3Prefs
got the same problem 5 days ago...
play in window mode still the same
any solution yet?
Same problem 5 day ago i cant play Wo and D3 ... BF3 no problem .... Shut down my computer ... ASUS ROG G 73 , GTX 460
BUMP! same problem!

Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120830-0333)
Language: Swedish (Regional Setting: Swedish)
System Manufacturer: MSI
System Model: MS-7752
BIOS: BIOS Date: 06/19/12 10:26:56 Ver: 04.06.05
Processor: Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz (8 CPUs), ~3.5GHz
Memory: 16384MB RAM
Available OS Memory: 16332MB RAM
Page File: 7174MB used, 25488MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode
Enterprise,

You'll need to ask your question in the European Technical Support forum as you have a European Battle.net account and play in that region only.

http://eu.battle.net/d3/en/forum/4436696/

Join the Conversation

Return to Forum